diff options
author | Ulrich Drepper <drepper@redhat.com> | 2004-11-27 20:57:44 +0000 |
---|---|---|
committer | Ulrich Drepper <drepper@redhat.com> | 2004-11-27 20:57:44 +0000 |
commit | 60e4523a0826bfedc5bc1f8f0f3f7e8d8d67adc5 (patch) | |
tree | f6097495eff5d96cdb5441f6fbdc59d87135408e | |
parent | 097487fef878799882bd444218cef836794abc5f (diff) | |
download | glibc-60e4523a0826bfedc5bc1f8f0f3f7e8d8d67adc5.tar.gz |
Update.
2004-11-27 Ulrich Drepper <drepper@redhat.com>
* posix/getconf.c (vars): Add support for _SC_IPV6 and
_SC_RAW_SOCKETS.
* sysdeps/posix/sysconf.c (__sysconf): Add support for _SC_IPV6
and _SC_RAW_SOCKETS.
* sysdeps/generic/bits/confname.h: Define _SC_IPV6 and
_SC_RAW_SOCKETS.
-rw-r--r-- | ChangeLog | 9 | ||||
-rw-r--r-- | bits/confname.h | 7 | ||||
-rw-r--r-- | linuxthreads/ChangeLog | 10 | ||||
-rw-r--r-- | nptl/ChangeLog | 10 | ||||
-rw-r--r-- | posix/getconf.c | 6 | ||||
-rw-r--r-- | sysdeps/generic/bits/confname.h | 7 | ||||
-rw-r--r-- | sysdeps/posix/sysconf.c | 14 |
7 files changed, 61 insertions, 2 deletions
@@ -1,3 +1,12 @@ +2004-11-27 Ulrich Drepper <drepper@redhat.com> + + * posix/getconf.c (vars): Add support for _SC_IPV6 and + _SC_RAW_SOCKETS. + * sysdeps/posix/sysconf.c (__sysconf): Add support for _SC_IPV6 + and _SC_RAW_SOCKETS. + * sysdeps/generic/bits/confname.h: Define _SC_IPV6 and + _SC_RAW_SOCKETS. + 2004-11-26 Jakub Jelinek <jakub@redhat.com> * sysdeps/generic/unsecvars.h (UNSECURE_ENVVARS): Add GETCONF_DIR. diff --git a/bits/confname.h b/bits/confname.h index d097a4ba1a..8947d48ed7 100644 --- a/bits/confname.h +++ b/bits/confname.h @@ -492,9 +492,14 @@ enum #define _SC_LEVEL4_CACHE_SIZE _SC_LEVEL4_CACHE_SIZE _SC_LEVEL4_CACHE_ASSOC, #define _SC_LEVEL4_CACHE_ASSOC _SC_LEVEL4_CACHE_ASSOC - _SC_LEVEL4_CACHE_LINESIZE + _SC_LEVEL4_CACHE_LINESIZE, #define _SC_LEVEL4_CACHE_LINESIZE _SC_LEVEL4_CACHE_LINESIZE /* Leave room here, maybe we need a few more cache levels some day. */ + + _SC_IPV6 = _SC_LEVEL1_ICACHE_SIZE + 50, +#define _SC_IPV6 _SC_IPV6 + _SC_RAW_SOCKETS +#define _SC_RAW_SOCKETS _SC_RAW_SOCKETS }; /* Values for the NAME argument to `confstr'. */ diff --git a/linuxthreads/ChangeLog b/linuxthreads/ChangeLog index 4b4a3c3390..3c797fe7f5 100644 --- a/linuxthreads/ChangeLog +++ b/linuxthreads/ChangeLog @@ -1,3 +1,13 @@ +2004-11-26 Jakub Jelinek <jakub@redhat.com> + + * sysdeps/unix/sysv/linux/bits/posix_opt.h (_POSIX_ADVISORY_INFO, + _POSIX_SPORADIC_SERVER, _POSIX_THREAD_SPORADIC_SERVER, _POSIX_TRACE, + _POSIX_TRACE_EVENT_FILTER, _POSIX_TRACE_INHERIT, _POSIX_TRACE_LOG, + _POSIX_TYPED_MEMORY_OBJECTS): Define. + * sysdeps/unix/sysv/linux/i386/bits/posix_opt.h: Likewise. + * sysdeps/unix/sysv/linux/ia64/bits/posix_opt.h: Likewise. + * sysdeps/unix/sysv/linux/x86_64/bits/posix_opt.h: Likewise. + 2004-11-05 Maciej W. Rozycki <macro@mips.com> * sysdeps/mips/pspinlock.c: Include <sgidefs.h>. Use _ABIO32, diff --git a/nptl/ChangeLog b/nptl/ChangeLog index efe1235107..902cbbfbf9 100644 --- a/nptl/ChangeLog +++ b/nptl/ChangeLog @@ -1,3 +1,13 @@ +2004-11-26 Jakub Jelinek <jakub@redhat.com> + + * sysdeps/unix/sysv/linux/bits/posix_opt.h (_POSIX_ADVISORY_INFO, + _POSIX_SPORADIC_SERVER, _POSIX_THREAD_SPORADIC_SERVER, _POSIX_TRACE, + _POSIX_TRACE_EVENT_FILTER, _POSIX_TRACE_INHERIT, _POSIX_TRACE_LOG, + _POSIX_TYPED_MEMORY_OBJECTS, _POSIX_IPV6, _POSIX_RAW_SOCKETS): Define. + * sysdeps/unix/sysv/linux/i386/bits/posix_opt.h: Likewise. + * sysdeps/unix/sysv/linux/ia64/bits/posix_opt.h: Likewise. + * sysdeps/unix/sysv/linux/x86_64/bits/posix_opt.h: Likewise. + 2004-11-24 Ulrich Drepper <drepper@redhat.com> * sysdeps/x86_64/Makefile [nptl]: Define CFLAGS-pthread_create.c. diff --git a/posix/getconf.c b/posix/getconf.c index 6175dfec26..5aac25e4ca 100644 --- a/posix/getconf.c +++ b/posix/getconf.c @@ -912,6 +912,12 @@ static const struct conf vars[] = { "LEVEL4_CACHE_ASSOC", _SC_LEVEL4_CACHE_ASSOC, SYSCONF }, #endif +#ifdef _SC_IPV6 + { "IPV6", _SC_IPV6, SYSCONF }, +#endif +#ifdef _SC_RAW_SOCKETS + { "RAW_SOCKETS", _SC_RAW_SOCKETS, SYSCONF }, +#endif { NULL, 0, SYSCONF } }; diff --git a/sysdeps/generic/bits/confname.h b/sysdeps/generic/bits/confname.h index d097a4ba1a..8947d48ed7 100644 --- a/sysdeps/generic/bits/confname.h +++ b/sysdeps/generic/bits/confname.h @@ -492,9 +492,14 @@ enum #define _SC_LEVEL4_CACHE_SIZE _SC_LEVEL4_CACHE_SIZE _SC_LEVEL4_CACHE_ASSOC, #define _SC_LEVEL4_CACHE_ASSOC _SC_LEVEL4_CACHE_ASSOC - _SC_LEVEL4_CACHE_LINESIZE + _SC_LEVEL4_CACHE_LINESIZE, #define _SC_LEVEL4_CACHE_LINESIZE _SC_LEVEL4_CACHE_LINESIZE /* Leave room here, maybe we need a few more cache levels some day. */ + + _SC_IPV6 = _SC_LEVEL1_ICACHE_SIZE + 50, +#define _SC_IPV6 _SC_IPV6 + _SC_RAW_SOCKETS +#define _SC_RAW_SOCKETS _SC_RAW_SOCKETS }; /* Values for the NAME argument to `confstr'. */ diff --git a/sysdeps/posix/sysconf.c b/sysdeps/posix/sysconf.c index de81c2120b..a4bc2e78b1 100644 --- a/sysdeps/posix/sysconf.c +++ b/sysdeps/posix/sysconf.c @@ -1189,6 +1189,20 @@ __sysconf (name) return zero which indicates that no information is available. */ return 0; + + case _SC_IPV6: +#ifdef _POSIX_IPV6 + return _POSIX_IPV6; +#else + return -1; +#endif + + case _SC_RAW_SOCKETS: +#ifdef _POSIX_RAW_SOCKETS + return _POSIX_RAW_SOCKETS; +#else + return -1; +#endif } } |