summaryrefslogtreecommitdiff
path: root/fuzzing/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'fuzzing/meson.build')
-rw-r--r--fuzzing/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/fuzzing/meson.build b/fuzzing/meson.build
index 259c6d91d..d69381c63 100644
--- a/fuzzing/meson.build
+++ b/fuzzing/meson.build
@@ -38,4 +38,14 @@ foreach target_name : fuzz_targets
c_args : extra_c_args,
dependencies : deps,
)
+
+ # If the FuzzingEngine isn’t available, build some unit tests to check that
+ # the fuzzing files do basically work. This doesn’t do any actual fuzzing though.
+ # Pass in the README as an arbitrary fuzzing input, just so we have something.
+ if not fuzzing_engine.found()
+ test(target_name, exe,
+ args : files('README.md'),
+ suite : 'fuzzing',
+ )
+ endif
endforeach