summaryrefslogtreecommitdiff
path: root/m4macros/Makefile.am
diff options
context:
space:
mode:
authorRyan Lortie <desrt@desrt.ca>2013-05-30 00:07:32 -0400
committerRyan Lortie <desrt@desrt.ca>2013-05-31 16:42:51 -0400
commit2cdad088380d6be6faff39aec9dbd2086bf21681 (patch)
tree3284dbe2b56eb391db35ed6694c3114127ada50c /m4macros/Makefile.am
parenta49ed84f92d736879d4209f0154d3da00401c4cd (diff)
downloadglib-2cdad088380d6be6faff39aec9dbd2086bf21681.tar.gz
Rework the build system for a new tests approachwip/test-cleanup
Perform a substantial cleanup of the build system with respect to building and installing testcases. By default, tests are no longer compiled as part of 'make'. They will be built when 'make check' is run. The old behaviour can be obtained with --enable-always-build-tests. --disable-modular-tests is gone (because tests are no longer built by default). There is no longer any way to cause 'make check' to be a no-op, but that's not very useful anyway. A new glibtests.m4 file is introduced. Along with a substantially expanded Makefile.decl, this provides for consistent handling of --enable-installed-tests and --enable-always-build-tests (mentioned above). Port our various test-installing Makefiles to the new framework. This is a net reduction of about ~350 lines of Makefile and configure.ac. This patch substantially improves the situation in the toplevel tests/ directory. Things are now somewhat under control there. There were some tests being built that weren't even being run and we run those now. The long-running GObject performance tests in this directory have been removed from 'make check' because they take too long. There is one regression in this patch: the appinfo tests can no longer be installed due to an inability to handle differently-generated data files for installed vs. uninstalled tests. I could probably work around this, but I lack the will to do so now and I think we may be able to fix this in GLib itself by introducing proper support for relative pathnames to desktop files.
Diffstat (limited to 'm4macros/Makefile.am')
-rw-r--r--m4macros/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/m4macros/Makefile.am b/m4macros/Makefile.am
index 75a9ca05a..971871ce7 100644
--- a/m4macros/Makefile.am
+++ b/m4macros/Makefile.am
@@ -1,4 +1,4 @@
-include $(top_srcdir)/Makefile.decl
+include $(top_srcdir)/glib.mk
installed_m4= glib-2.0.m4 glib-gettext.m4 gsettings.m4