summaryrefslogtreecommitdiff
path: root/gobject/Makefile.am
diff options
context:
space:
mode:
authorGiovanni Campagna <gcampagna@src.gnome.org>2011-04-03 15:51:04 +0200
committerColin Walters <walters@verbum.org>2011-05-19 17:39:33 -0400
commit7c63370e3a81c9d6138924e88d868005414c08aa (patch)
tree6c989e7de9def2538a54ed5425e71d6ad86766de /gobject/Makefile.am
parent9793919d7b6a1469f1d7b43a500cd4ec99234621 (diff)
downloadglib-7c63370e3a81c9d6138924e88d868005414c08aa.tar.gz
GObject: move GLib type definitions to a separate header
This way it is possible to pull them into the GLib GIR file. Some cleanups by Colin Walters <walters@verbum.org> https://bugzilla.gnome.org/show_bug.cgi?id=646635
Diffstat (limited to 'gobject/Makefile.am')
-rw-r--r--gobject/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/gobject/Makefile.am b/gobject/Makefile.am
index c013a2f68..0a9dc0f4b 100644
--- a/gobject/Makefile.am
+++ b/gobject/Makefile.am
@@ -91,6 +91,7 @@ libgobject_2_0_la_DEPENDENCIES = $(gobject_win32_res) $(gobject_def)
#
# GObject library header files for public installation
gobject_public_h_sources = \
+ glib-types.h \
gbinding.h \
gboxed.h \
gclosure.h \
@@ -292,7 +293,7 @@ dist-hook: $(BUILT_EXTRA_DIST) ../build/win32/vs9/gobject.vcproj ../build/win32/
done >libgobject.vs10.sourcefiles
$(CPP) -P - <$(top_srcdir)/build/win32/vs10/gobject.vcxprojin >$@
rm libgobject.vs10.sourcefiles
-
+
../build/win32/vs10/gobject.vcxproj.filters: $(top_srcdir)/build/win32/vs10/gobject.vcxproj.filtersin
for F in $(libgobject_2_0_la_SOURCES); do \
case $$F in \
@@ -300,9 +301,9 @@ dist-hook: $(BUILT_EXTRA_DIST) ../build/win32/vs9/gobject.vcproj ../build/win32/
;; \
esac; \
done >libgobject.vs10.sourcefiles.filters
- $(CPP) -P - <$(top_srcdir)/build/win32/vs10/gobject.vcxproj.filtersin >$@
+ $(CPP) -P - <$(top_srcdir)/build/win32/vs10/gobject.vcxproj.filtersin >$@
rm libgobject.vs10.sourcefiles.filters
-
+
install-data-local: install-ms-lib install-def-file
uninstall-local: uninstall-ms-lib uninstall-def-file uninstall-gdb