summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-15 22:57:25 -0400
committerWilliam Hua <william@attente.ca>2012-04-18 00:00:29 -0400
commitb3f814883f460ec9b309552a501652ecdecfb2dc (patch)
tree795fea593fd77606b9556b59f4191c8f0757a8a5 /configure.ac
parenta147004b83ee48265e266e33da7656a3a09c7edb (diff)
downloadglib-b3f814883f460ec9b309552a501652ecdecfb2dc.tar.gz
Do not detect GNUstep as Cocoa
GNUstep also installs Foundation/Foundation.h https://bugzilla.gnome.org/show_bug.cgi?id=674172 Signed-off-by: William Hua <william@attente.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 839b8a462..466cf435c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -179,6 +179,9 @@ glib_have_cocoa=no
AC_MSG_CHECKING([for Mac OS X Cocoa support])
AC_TRY_CPP([
#include <Cocoa/Cocoa.h>
+#ifdef GNUSTEP_BASE_VERSION
+#error "Detected GNUstep, not Cocoa"
+#endif
], glib_have_cocoa=yes)
AC_MSG_RESULT([$glib_have_cocoa])