summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2012-04-12 13:54:55 -0400
committerColin Walters <walters@verbum.org>2012-04-15 11:15:54 -0400
commit4b98c512df9102086f9c6babb04fed3533b73925 (patch)
tree2039a57ff67b1aea403ca53bdc3217b47b0ce6b4 /configure.ac
parentf084b603771f78126bc0b07229a1574b76e776bb (diff)
downloadglib-4b98c512df9102086f9c6babb04fed3533b73925.tar.gz
build: When cross compiling, don't require host binaries if tests are not enabled
These binaries are now only used by the test suite. glib-genmarshal *used* to be required to generate marshallers, but isn't anymore now that we use libffi (via g_cclosure_marshal_generic). https://bugzilla.gnome.org/show_bug.cgi?id=667806
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c93fcec69..72a1cb159 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2568,7 +2568,7 @@ dnl ******************************************************************
AM_CONDITIONAL(CROSS_COMPILING, test $cross_compiling = yes)
-if test $cross_compiling = yes; then
+if test $cross_compiling = yes && test x$enable_modular_tests = xyes; then
AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal, no)
if test x$GLIB_GENMARSHAL = xno; then
AC_MSG_ERROR(Could not find a glib-genmarshal in your PATH)