summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 32793f6..c38efda 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,15 +33,6 @@ set(COMMON_CFLAGS "${COMMON_CFLAGS} ${GIT2_CFLAGS}")
set(COMMON_LDFLAGS "${COMMON_LDFLAGS} ${GIT2_LDFLAGS}")
set(COMMON_LIBS "${COMMON_LIBS};${GIT2_LIBRARIES}")
-## check for git_repository_open_no_backend() function.
-include(CheckCSourceCompiles)
-set(CMAKE_REQUIRED_LIBRARIES "${GIT2_LIBRARIES}")
-check_c_source_compiles("
- #include <git2.h>
- int main(int argc, char *argv[]) {
- return git_repository_open_no_backend(NULL,NULL,NULL,NULL,NULL);
- }" HAVE_git_repository_open_no_backend)
-
## LuaNativeObjects
include(LuaNativeObjects)