summaryrefslogtreecommitdiff
path: root/src/CommonAPI/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CommonAPI/CMakeLists.txt')
-rw-r--r--src/CommonAPI/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/CommonAPI/CMakeLists.txt b/src/CommonAPI/CMakeLists.txt
new file mode 100644
index 0000000..73d1046
--- /dev/null
+++ b/src/CommonAPI/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required (VERSION 2.8.1)
+FIND_PACKAGE(PkgConfig)
+set(CAPI_LIB_SRCS *.cpp )
+add_library(CommonAPI ${shm_LIB_SRCS})
+target_link_libraries(CommonAPI ${EXPAT_LIBRARIES})
+set_target_properties(CommonAPI PROPERTIES VERSION 3.0.0 SOVERSION 0 LINKER_LANGUAGE C)
+
+set(CAPI_DEV_INCL *.h )
+
+install(TARGETS CommonAPI
+ LIBRARY DESTINATION /usr/lib
+ ARCHIVE DESTINATION lib/static
+ COMPONENT base)