summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Henstridge <james@daa.com.au>2000-07-25 14:44:33 +0000
committerJames Henstridge <jamesh@src.gnome.org>2000-07-25 14:44:33 +0000
commite9ca74667fa151cd3df3d9892f1a7daec9f30379 (patch)
treeabeb633372c0ace829800cedd5528eb3b79c4eda /Makefile.am
parent377edb91b0af687f6ae5784d94bc2320b8f38d44 (diff)
downloadgconf-e9ca74667fa151cd3df3d9892f1a7daec9f30379.tar.gz
make relative symlinks rather than absolute path symlinks. Again to help
2000-07-25 James Henstridge <james@daa.com.au> * Makefile.am, gconf/Makefile.am: make relative symlinks rather than absolute path symlinks. Again to help packagers. * configure.in (GCONF_CONFIG_SOURCE): don't use EXPANDED_SYSCONFDIR hack. Instead just escape the dollar sign in ${sysconfdir}. This fixes build root installs used when building packages.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 19e2404d..d566475a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,7 +13,7 @@ all-local:
install-exec-local:
$(INSTALL_SCRIPT) gconf-config $(bindir)/gconf-config-$(MAJOR_VERSION)
- $(LN_S) -f $(bindir)/gconf-config-$(MAJOR_VERSION) $(bindir)/gconf-config
+ (cd $(bindir) && $(LN_S) -f gconf-config-$(MAJOR_VERSION) gconf-config)
echo "**** NOTE ****" && \
echo $(WARNING_MESSAGE) && \
echo "**************"