summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMark McLoughlin <mark@skynet.ie>2004-09-14 19:58:09 +0000
committerMark McLoughlin <markmc@src.gnome.org>2004-09-14 19:58:09 +0000
commit51acca32d54d8ae00d5a4324de588ccace69fc0f (patch)
tree4f794a5c2dede7bc93033193c41938776cf84cbe /Makefile.am
parentb580082063c1eb544d9c8c4499afdeba4ff35e69 (diff)
downloadgconf-51acca32d54d8ae00d5a4324de588ccace69fc0f.tar.gz
Version 2.8.0.1.GCONF_2_8_0_1
2004-09-13 Mark McLoughlin <mark@skynet.ie> * configure.in: Version 2.8.0.1. 2004-09-14 Mark McLoughlin <mark@skynet.ie> * autogen.sh: use automake 1.7 and run gtkdocize. * configure.in: check for glib-genmarshal and use GTK_DOC_CHECK. * Makefile.am: add --enable-gtk-doc to DISTCHECK_CONFIGURE_FLAGS. * gconf/Makefile.am: re-do how the marshallers are generated. * doc/gconf/Makefile.am: use gtk-doc.make. * doc/gconf/gconf.sgml: tweak to validate. * backends/Makefile.am: make xml-test link against the backend rather than rebuilding the sources. * gconf-2.m4.in: rename from gconf.m4.in.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 14 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 27bf1dbc..fcdac65a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,12 +2,19 @@
SUBDIRS = gconf backends po doc examples
DIST_SUBDIRS=tests $(SUBDIRS)
-EXTRA_DIST=gconf.m4.in TODO \
- gconf-2.0.pc.in
+EXTRA_DIST = \
+ gconf-2.m4.in \
+ TODO \
+ gconf-2.0.pc.in \
+ gtk-doc.make
+
+DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
+DISTCLEANFILES = \
+ intltool-extract \
+ intltool-merge \
+ intltool-update
install-data-local:
- -mkdir -p $(DESTDIR)$(datadir)/aclocal
- $(INSTALL_DATA) gconf.m4 $(DESTDIR)$(datadir)/aclocal/gconf-$(MAJOR_VERSION).m4
-mkdir -p $(DESTDIR)$(sysgconfdir)/gconf.xml.defaults
-chmod 755 $(DESTDIR)$(sysgconfdir)/gconf.xml.defaults
-mkdir -p $(DESTDIR)$(sysgconfdir)/gconf.xml.mandatory
@@ -16,5 +23,8 @@ install-data-local:
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = gconf-2.0.pc
+aclocaldir = $(datadir)/aclocal
+aclocal_DATA = gconf-2.m4
+
install-schemas:
(cd standard-schemas && $(MAKE) $(AM_MAKEFLAGS) install-schemas)