summaryrefslogtreecommitdiff
path: root/libobjc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'libobjc/configure.in')
-rw-r--r--libobjc/configure.in28
1 files changed, 0 insertions, 28 deletions
diff --git a/libobjc/configure.in b/libobjc/configure.in
index 51554522e96..fcfcd87da24 100644
--- a/libobjc/configure.in
+++ b/libobjc/configure.in
@@ -38,34 +38,6 @@ AC_SUBST(target_alias)
GLIBCPP_CONFIGURE(.)
GLIBCPP_EXPORT_INSTALL_INFO
-# If the language specific compiler does not exist, but the "gcc" directory
-# does, we do not build anything. Note, $r is set by the top-level Makefile.
-# Note that when we look for the compiler, we search both with and without
-# extension to handle cross and canadian cross builds.
-compiler_name=cc1obj
-rm -f skip-this-dir
-AC_MSG_CHECKING(if compiler $compiler_name has been built)
-AC_CACHE_VAL(objc_cv_compiler_exists,
-[objc_cv_compiler_exists=yes
-if test -n "$r"; then
- if test -d "$r"/gcc; then
- if test -f "$r"/gcc/$compiler_name \
- || test -f "$r"/gcc/$compiler_name.exe; then
- true
- else
- objc_cv_compiler_exists=no
- echo "rm -f config.cache config.log multilib.out" > skip-this-dir
- fi
- fi
-fi
-])
-AC_MSG_RESULT($objc_cv_compiler_exists)
-if test x$objc_cv_compiler_exists = xno
-then
- rm -f Makefile conftest* confdefs* core
- exit 0
-fi
-
dnl Checks for programs.
# Disable shared libs by default