summaryrefslogtreecommitdiff
path: root/libjava/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'libjava/configure.in')
-rw-r--r--libjava/configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/libjava/configure.in b/libjava/configure.in
index 4549889467d..861530a2e49 100644
--- a/libjava/configure.in
+++ b/libjava/configure.in
@@ -42,6 +42,17 @@ AC_ARG_ENABLE(libgcj-debug,
AC_DEFINE(DEBUG)
fi)
+dnl See if the user has the enterpreter included.
+AC_ARG_ENABLE(interpreter,
+[ --enable-interpreter Enable interpreter],
+ if test "$enable_interpreter" = yes; then
+ AC_DEFINE(INTERPRETER)
+ fi)
+
+dnl This becomes -lffi if the interpreter is enables
+INTERPSPEC=
+AC_SUBST(INTERPSPEC)
+
dnl If the target is an eCos system, use the appropriate eCos
dnl I/O routines.
dnl FIXME: this should not be a local option but a global target
@@ -447,6 +458,10 @@ else
])
SYSTEMSPEC="$SYSTEMSPEC $gcj_cv_lib_sockets"
+ if test "$enable_interpreter" = yes; then
+ INTERPSPEC=
+ fi
+
if test "$with_system_zlib" = yes; then
AC_CHECK_LIB(z, deflate, ZLIBSPEC=-lz, ZLIBSPEC=-lzgcj)
else