summaryrefslogtreecommitdiff
path: root/libitm/testsuite/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libitm/testsuite/Makefile.am')
-rw-r--r--libitm/testsuite/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/libitm/testsuite/Makefile.am b/libitm/testsuite/Makefile.am
new file mode 100644
index 00000000000..561b7e25448
--- /dev/null
+++ b/libitm/testsuite/Makefile.am
@@ -0,0 +1,13 @@
+## Process this file with automake to produce Makefile.in.
+
+AUTOMAKE_OPTIONS = foreign dejagnu
+
+# May be used by various substitution variables.
+gcc_version := $(shell cat $(top_srcdir)/../gcc/BASE-VER)
+
+EXPECT = $(shell if test -f $(top_builddir)/../expect/expect; then \
+ echo $(top_builddir)/../expect/expect; else echo expect; fi)
+
+_RUNTEST = $(shell if test -f $(top_srcdir)/../dejagnu/runtest; then \
+ echo $(top_srcdir)/../dejagnu/runtest; else echo runtest; fi)
+RUNTEST = "$(_RUNTEST) $(AM_RUNTESTFLAGS)"