summaryrefslogtreecommitdiff
path: root/libgo/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libgo/Makefile.am')
-rw-r--r--libgo/Makefile.am11
1 files changed, 3 insertions, 8 deletions
diff --git a/libgo/Makefile.am b/libgo/Makefile.am
index 0f9881ffaa4..9800d20bd9b 100644
--- a/libgo/Makefile.am
+++ b/libgo/Makefile.am
@@ -399,12 +399,6 @@ rtems_task_variable_add_file =
endif
if LIBGO_IS_LINUX
-runtime_thread_files = runtime/thread-linux.c
-else
-runtime_thread_files = runtime/thread-sema.c
-endif
-
-if LIBGO_IS_LINUX
runtime_getncpu_file = runtime/getncpu-linux.c
else
if LIBGO_IS_DARWIN
@@ -469,7 +463,6 @@ runtime_files = \
runtime/runtime_c.c \
runtime/stack.c \
runtime/thread.c \
- $(runtime_thread_files) \
runtime/yield.c \
$(rtems_task_variable_add_file) \
$(runtime_getncpu_file)
@@ -543,6 +536,8 @@ s-sigtab: $(srcdir)/mksigtab.sh gen-sysinfo.go
# _Complex_lock and _Reader_lock are Go translations of some AIX system
# types and should not be exported back to C
+# semt is a Go translation of the C type sem_t; it fails to convert on
+# some systems and need not be exported back to C.
# sigset conflicts with system type sigset on AIX, so we need to rename it
runtime.inc: s-runtime-inc; @true
s-runtime-inc: runtime.lo Makefile
@@ -551,7 +546,7 @@ s-runtime-inc: runtime.lo Makefile
for pattern in '_[GP][a-z]' _Max _Lock _Sig _Trace _MHeap _Num; do \
grep "#define $$pattern" runtime.inc.tmp >> runtime.inc.tmp2; \
done
- for TYPE in _Complex_lock _Reader_lock; do \
+ for TYPE in _Complex_lock _Reader_lock semt; do \
sed -e '/struct '$${TYPE}' {/,/^}/s/^.*$$//' runtime.inc.tmp2 > runtime.inc.tmp3; \
mv runtime.inc.tmp3 runtime.inc.tmp2; \
done