summaryrefslogtreecommitdiff
path: root/libffi/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libffi/Makefile.am')
-rw-r--r--libffi/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/libffi/Makefile.am b/libffi/Makefile.am
index 91c5080f029..cfe1f7abe02 100644
--- a/libffi/Makefile.am
+++ b/libffi/Makefile.am
@@ -21,8 +21,14 @@ MULTISUBDIR =
MULTIDO = true
MULTICLEAN = true
+## Install a library built with a cross compiler in tooldir, not
+## libdir.
+if USE_LIBDIR
+toolexeclibdir = $(libdir)$(MULTISUBDIR)
+else
toolexecdir = $(exec_prefix)/$(target_alias)
toolexeclibdir = $(toolexecdir)/lib$(MULTISUBDIR)
+endif
toolexeclib_LTLIBRARIES = libffi.la