summaryrefslogtreecommitdiff
path: root/libbanshee/points-to/andersen_terms.spec
diff options
context:
space:
mode:
Diffstat (limited to 'libbanshee/points-to/andersen_terms.spec')
-rw-r--r--libbanshee/points-to/andersen_terms.spec34
1 files changed, 34 insertions, 0 deletions
diff --git a/libbanshee/points-to/andersen_terms.spec b/libbanshee/points-to/andersen_terms.spec
new file mode 100644
index 00000000000..244f643f908
--- /dev/null
+++ b/libbanshee/points-to/andersen_terms.spec
@@ -0,0 +1,34 @@
+% Copyright (c) 2000-2001
+% The Regents of the University of California. All rights reserved.
+%
+% Redistribution and use in source and binary forms, with or without
+% modification, are permitted provided that the following conditions
+% are met:
+% 1. Redistributions of source code must retain the above copyright
+% notice, this list of conditions and the following disclaimer.
+% 2. Redistributions in binary form must reproduce the above copyright
+% notice, this list of conditions and the following disclaimer in the
+% documentation and/or other materials provided with the distribution.
+% 3. Neither the name of the University nor the names of its contributors
+% may be used to endorse or promote products derived from this software
+% without specific prior written permission.
+%
+% THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+% ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+% IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+% ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
+% FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+% DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+% OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+% HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+% LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+% OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+% SUCH DAMAGE.
+
+specification andersen_terms : ANDERSEN_TERMS =
+ spec
+ data label_term : set
+ data aterm : set = ref of +label_term * -aterm * +aterm
+ | lam of +label_term * -argterm * +aterm
+ and argterm : row(aterm)
+ end