summaryrefslogtreecommitdiff
path: root/libatomic/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libatomic/Makefile.am')
-rw-r--r--libatomic/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/libatomic/Makefile.am b/libatomic/Makefile.am
index fdc16c0ac91..b3512442850 100644
--- a/libatomic/Makefile.am
+++ b/libatomic/Makefile.am
@@ -139,3 +139,10 @@ endif
libatomic_convenience_la_SOURCES = $(libatomic_la_SOURCES)
libatomic_convenience_la_LIBADD = $(libatomic_la_LIBADD)
+
+# Override the automake generated all-multi rule to guarantee that all-multi
+# is not run in parallel with the %_.lo rules which generate $(DEPDIR)/*.Ppo
+# makefile fragments to avoid broken *.Ppo getting included into the Makefile
+# when it is reloaded during the build of all-multi.
+all-multi: $(libatomic_la_LIBADD)
+ $(MULTIDO) $(AM_MAKEFLAGS) DO=all multi-do # $(MAKE)