summaryrefslogtreecommitdiff
path: root/gnattools/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gnattools/configure.ac')
-rw-r--r--gnattools/configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnattools/configure.ac b/gnattools/configure.ac
index cd5e8402bd9..965dc8e18e5 100644
--- a/gnattools/configure.ac
+++ b/gnattools/configure.ac
@@ -51,13 +51,6 @@ ACX_NONCANONICAL_TARGET
# Need to pass this down for now :-P
AC_PROG_LN_S
-# Determine x_ada_cflags
-case $host in
- hppa*) x_ada_cflags=-mdisable-indexing ;;
- *) x_ada_cflags= ;;
-esac
-AC_SUBST([x_ada_cflags])
-
# Determine what to build for 'gnattools'
if test $build = $target ; then
# Note that build=target is almost certainly the wrong test; FIXME
@@ -160,6 +153,9 @@ case "${target}" in
;;
esac
+# From user or toplevel makefile.
+AC_SUBST(ADA_CFLAGS)
+
# Output: create a Makefile.
AC_CONFIG_FILES([Makefile])