summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 49ca32a1410..dc8ebedf0a9 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -2600,6 +2600,23 @@ case "$target" in
[Define if your MIPS libgloss linker scripts consistently include STARTUP directives.])
fi
AC_MSG_RESULT($gcc_cv_mips_libgloss_startup)
+
+ AC_MSG_CHECKING(whether the assembler has explicit relocation support)
+ if test x$gcc_cv_mips_explicit_relocs = x; then
+ gcc_cv_mips_explicit_relocs=no
+ if test x$gcc_cv_as != x; then
+ echo ' lw $4,%gp_rel(foo)($4)' > conftest.s
+ if $gcc_cv_as conftest.s -o conftest.o > /dev/null 2>&1; then
+ gcc_cv_mips_explicit_relocs=yes
+ fi
+ rm -f conftest.s conftest.o
+ fi
+ fi
+ if test $gcc_cv_mips_explicit_relocs = yes; then
+ test x$target_cpu_default != x || target_cpu_default=0
+ target_cpu_default="(${target_cpu_default}|MASK_EXPLICIT_RELOCS)"
+ fi
+ AC_MSG_RESULT($gcc_cv_mips_explicit_relocs)
;;
esac