summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index d7597d28341..79de6cd7964 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -4041,6 +4041,14 @@ changequote([,])dnl
all_compilers="$all_compilers $compilers"
all_outputs="$all_outputs $outputs"
all_gtfiles="$all_gtfiles [[$subdir]] $gtfiles"
+ case ",$enable_languages," in
+ *,lto,*)
+ AC_DEFINE(ENABLE_LTO, 1, [Define to enable LTO support.])
+ enable_lto=yes
+ AC_SUBST(enable_lto)
+ ;;
+ *) ;;
+ esac
done
# Pick up gtfiles for c
@@ -4213,6 +4221,12 @@ if test "x${CLOOGLIBS}" != "x" ; then
AC_DEFINE(HAVE_cloog, 1, [Define if cloog is in use.])
fi
+AC_ARG_VAR(LIBELFLIBS,[How to link libelf])
+AC_ARG_VAR(LIBELFINC,[How to find libelf include files])
+if test "x${LIBELFLIBS}" != "x" ; then
+ AC_DEFINE(HAVE_libelf, 1, [Define if libelf is in use.])
+fi
+
# Check for plugin support
AC_ARG_ENABLE(plugin,
[ --enable-plugin enable plugin support],