summaryrefslogtreecommitdiff
path: root/fastjar/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fastjar/Makefile.am')
-rw-r--r--fastjar/Makefile.am34
1 files changed, 15 insertions, 19 deletions
diff --git a/fastjar/Makefile.am b/fastjar/Makefile.am
index fa31b9235fb..21629654f4c 100644
--- a/fastjar/Makefile.am
+++ b/fastjar/Makefile.am
@@ -70,28 +70,24 @@ EXTRA_DIST = $(man_MANS)
## available in 1.4. Nor can we override or append to MAKEINFO or
## MAKEINFOFLAGS, since these are overridden by the top-level
## Makefile. So, we just duplicate the rules. FIXME: remove this
-## when we upgrade automake. Note that we don't include $(srcdir) in
-## my_makei_flags; makeinfo is run in srcdir.
-my_makei_flags += -I ../gcc/doc/include
+## when we upgrade automake.
+my_makei_flags += -I $(srcdir)/../gcc/doc/include
fastjar.info: fastjar.texi $(fastjar_TEXINFOS)
- @cd $(srcdir) && rm -f $@ $@-[0-9] $@-[0-9][0-9]
- cd $(srcdir) \
- && $(MAKEINFO) $(my_makei_flags) `echo $< | sed 's,.*/,,'`
-
+ rm -f $@ $@-[0-9] $@-[0-9][0-9]
+ $(MAKEINFO) $(my_makei_flags) -o $@ $<
TEXI2POD = perl $(srcdir)/../contrib/texi2pod.pl
POD2MAN = pod2man --center="GNU" --release="gcc-@gcc_version@"
-$(srcdir)/jar.1: $(srcdir)/fastjar.texi
- -$(TEXI2POD) -D jar < $(srcdir)/fastjar.texi > fastjar.pod
- -($(POD2MAN) --section=1 fastjar.pod > jar.1.T$$$$ && \
- mv -f jar.1.T$$$$ $(srcdir)/jar.1) || \
- (rm -f jar.1.T$$$$ && exit 1)
- -rm -f fastjar.pod
+%.1: %.pod
+ -($(POD2MAN) --section=1 $< > $(@).T$$$$ && \
+ mv -f $(@).T$$$$ $@) || \
+ (rm -f $(@).T$$$$ && exit 1)
+
+.INTERMEDIATE: jar.pod grepjar.pod
+
+jar.pod: $(srcdir)/fastjar.texi
+ -$(TEXI2POD) -D jar $< > $@
-$(srcdir)/grepjar.1: $(srcdir)/fastjar.texi
- -$(TEXI2POD) -D grepjar < $(srcdir)/fastjar.texi > grepjar.pod
- -($(POD2MAN) --section=1 grepjar.pod > grepjar.1.T$$$$ && \
- mv -f grepjar.1.T$$$$ $(srcdir)/grepjar.1) || \
- (rm -f grepjar.1.T$$$$ && exit 1)
- -rm -f grepjar.pod
+grepjar.pod: $(srcdir)/fastjar.texi
+ -$(TEXI2POD) -D grepjar $< > $@