summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9fee56378e1..b97c5051044 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1982,6 +1982,14 @@ case ,${enable_languages},:${enable_objc_gc} in
;;
esac
+# Disable libitm if we're not building C++
+case ,${enable_languages}, in
+ *,c++) ;;
+ *)
+ noconfigdirs="$noconfigdirs target-libitm"
+ ;;
+esac
+
# Remove the entries in $skipdirs and $noconfigdirs from $configdirs,
# $build_configdirs and $target_configdirs.
# If we have the source for $noconfigdirs entries, add them to $notsupp.