summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index e64e5775f13..4cf11607365 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1139,10 +1139,11 @@ AC_ARG_ENABLE([bootstrap],
enable_bootstrap=default)
# Issue errors and warnings for invalid/strange bootstrap combinations.
-case "$configdirs" in
- *gcc*) have_compiler=yes ;;
- *) have_compiler=no ;;
-esac
+if test -r $srcdir/gcc/configure; then
+ have_compiler=yes
+else
+ have_compiler=no
+fi
case "$have_compiler:$host:$target:$enable_bootstrap" in
*:*:*:no) ;;