summaryrefslogtreecommitdiff
path: root/boehm-gc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'boehm-gc/configure.in')
-rw-r--r--boehm-gc/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/boehm-gc/configure.in b/boehm-gc/configure.in
index 182277a3cd4..29725423b2a 100644
--- a/boehm-gc/configure.in
+++ b/boehm-gc/configure.in
@@ -62,6 +62,7 @@ if test "$THREADS" = yes; then
fi
INCLUDES=
+THREADLIB=
case "$THREADS" in
no | none | single)
THREADS=none
@@ -81,10 +82,12 @@ case "$THREADS" in
AC_DEFINE(IRIX_THREADS)
;;
esac
+ THREADLIB=-lpthread
;;
qt)
AC_DEFINE(QUICK_THREADS)
INCLUDES="-I${boehm_gc_basedir}/../qthreads"
+ THREADLIB=../qthreads/libgcjcoop.la
;;
decosf1 | irix | mach | os2 | solaris | win32 | dce | vxworks)
AC_MSG_ERROR(thread package $THREADS not yet supported)
@@ -94,6 +97,7 @@ case "$THREADS" in
;;
esac
AC_MSG_RESULT($THREADS)
+AC_SUBST(THREADLIB)
AC_ARG_ENABLE(java-gc,
changequote(<<,>>)dnl