summaryrefslogtreecommitdiff
path: root/boehm-gc/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'boehm-gc/configure.ac')
-rw-r--r--boehm-gc/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/boehm-gc/configure.ac b/boehm-gc/configure.ac
index 326a051f767..2206f76eaa2 100644
--- a/boehm-gc/configure.ac
+++ b/boehm-gc/configure.ac
@@ -84,6 +84,13 @@ case "${host}" in
;;
esac
+dnl Add for mingw targets GC_BUILD option
+case "${host}" in
+ *-*-mingw*)
+ gc_cflags="${gc_cflags} -DGC_BUILD=1"
+ ;;
+esac
+
dnl gc_cflags="${gc_cflags} -fno-builtin"
GC_CFLAGS=${gc_cflags}