summaryrefslogtreecommitdiff
path: root/boehm-gc/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'boehm-gc/configure.ac')
-rw-r--r--boehm-gc/configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/boehm-gc/configure.ac b/boehm-gc/configure.ac
index 5c26b8454fc..29331e607d6 100644
--- a/boehm-gc/configure.ac
+++ b/boehm-gc/configure.ac
@@ -173,8 +173,12 @@ case "$THREADS" in
THREADLIBS=-pthread
;;
*-*-solaris*)
- AC_DEFINE(GC_SOLARIS_THREADS,1,[support for Solaris (thr_) threads])
AC_DEFINE(GC_SOLARIS_PTHREADS,1,[support for Solaris pthreads])
+ # Need to use alternate thread library, otherwise gctest hangs
+ # on Solaris 8.
+ multi_os_directory=`$CC -print-multi-os-directory`
+ THREADLIBS="-L/usr/lib/lwp/$multi_os_directory \
+ -R/usr/lib/lwp/$multi_os_directory -lpthread -lthread -lrt"
;;
*-*-irix*)
AC_DEFINE(GC_IRIX_THREADS,1,[support for Irix pthreads])