summaryrefslogtreecommitdiff
path: root/boehm-gc/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'boehm-gc/configure.ac')
-rw-r--r--boehm-gc/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/boehm-gc/configure.ac b/boehm-gc/configure.ac
index d4dd16b9e06..5c26b8454fc 100644
--- a/boehm-gc/configure.ac
+++ b/boehm-gc/configure.ac
@@ -300,6 +300,14 @@ case "$host" in
;;
esac
+# extra LD Flags which are required for targets
+case "${host}" in
+ *-*-darwin*)
+ extra_ldflags_libgc=-Wl,-single_module
+ ;;
+esac
+AC_SUBST(extra_ldflags_libgc)
+
AC_SUBST(EXTRA_TEST_LIBS)
target_all=libgcjgc.la