summaryrefslogtreecommitdiff
path: root/boehm-gc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'boehm-gc/Makefile.am')
-rw-r--r--boehm-gc/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/boehm-gc/Makefile.am b/boehm-gc/Makefile.am
index 567d5979e5e..41528ae14ea 100644
--- a/boehm-gc/Makefile.am
+++ b/boehm-gc/Makefile.am
@@ -66,7 +66,8 @@ TESTS = gctest
## CFLAGS, not those passed in from the top level make.
LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(AM_CPPFLAGS) $(CPPFLAGS) \
$(AM_CFLAGS) $(MY_CFLAGS) $(GC_CFLAGS)
-LINK = $(LIBTOOL) --mode=link $(CC) $(AM_CFLAGS) $(MY_CFLAGS) $(LDFLAGS) -o $@
+LTLDFLAGS = $(shell $(top_srcdir)/../libtool-ldflags $(LDFLAGS))
+LINK = $(LIBTOOL) --mode=link $(CC) $(AM_CFLAGS) $(MY_CFLAGS) $(LTLDFLAGS) -o $@
# Work around what appears to be a GNU make bug handling MAKEFLAGS
# values defined in terms of make variables, as is the case for CC and