summaryrefslogtreecommitdiff
path: root/lto-plugin/Makefile.am
diff options
context:
space:
mode:
authorro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2010-12-15 16:56:26 +0000
committerro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2010-12-15 16:56:26 +0000
commit802cd8f49ea9fc6e6c6f811f5241eced5f08e535 (patch)
tree770118d389764aaa75356802d1f89efe6aaccb0c /lto-plugin/Makefile.am
parentf34176804e2196c830e12dd6a8ab2ccad6685957 (diff)
downloadgcc-802cd8f49ea9fc6e6c6f811f5241eced5f08e535.tar.gz
Revert last change.
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@167859 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'lto-plugin/Makefile.am')
-rw-r--r--lto-plugin/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/lto-plugin/Makefile.am b/lto-plugin/Makefile.am
index 778f99c6746..ba385c76c6f 100644
--- a/lto-plugin/Makefile.am
+++ b/lto-plugin/Makefile.am
@@ -13,13 +13,11 @@ AM_CFLAGS = -Wall -Werror
libexecsub_LTLIBRARIES = liblto_plugin.la
liblto_plugin_la_SOURCES = lto-plugin.c
-liblto_plugin_la_DEPENDENCIES = \
- $(if $(wildcard ../libiberty/pic/libiberty.a),../libiberty/pic/libiberty.a,)
liblto_plugin_la_LIBADD = \
- $(if $(wildcard ../libiberty/pic/libiberty.a),-L../libiberty/pic -liberty,)
+ $(if $(wildcard ../libiberty/pic/libiberty.a),../libiberty/pic/libiberty.a,)
# Note that we intentionally override the bindir supplied by ACX_LT_HOST_FLAGS
liblto_plugin_la_LDFLAGS = $(lt_host_flags) -bindir $(libexecsubdir) \
- $(if $(wildcard ../libiberty/pic/libiberty.a),,-L../libiberty -liberty)
+ $(if $(wildcard ../libiberty/pic/libiberty.a),,-Wc,../libiberty/libiberty.a)
all: copy_lto_plugin