summaryrefslogtreecommitdiff
path: root/libstdc++-v3/testsuite/Makefile.am
diff options
context:
space:
mode:
authorMark Mitchell <mark@codesourcery.com>2005-04-01 20:20:22 +0000
committerMark Mitchell <mmitchel@gcc.gnu.org>2005-04-01 20:20:22 +0000
commitfdbba6bcf007f4691936c39fd4a508d3bbbed0bb (patch)
treea0f95ae69cfd718b19b083c95a258e99a23146ad /libstdc++-v3/testsuite/Makefile.am
parentc6cc541b36aaf32335a6e4b420b55bf7c9a979be (diff)
downloadgcc-fdbba6bcf007f4691936c39fd4a508d3bbbed0bb.tar.gz
Makefile.am (noinst_PROGRAMS): Remove.
* testsuite/Makefile.am (noinst_PROGRAMS): Remove. (site.exp): Write out the path to the baseline file. (check-abi): Use DejaGNU. (check-abi-verbose): Remove. * testsuite/Makefile.in: Regenerated. * testsuite/abi_check.cc (main): Check the return value from compare_symbols. * testsuite/testsuite_abi.cc (compare_symbols): Return a value. * testsuite/testsuite_abi.h (compare_symbols): Adjust prototype. * testsuite/libstdc++-abi/abi.exp: New file. From-SVN: r97417
Diffstat (limited to 'libstdc++-v3/testsuite/Makefile.am')
-rw-r--r--libstdc++-v3/testsuite/Makefile.am23
1 files changed, 3 insertions, 20 deletions
diff --git a/libstdc++-v3/testsuite/Makefile.am b/libstdc++-v3/testsuite/Makefile.am
index 868e58beeb1..3cfa19b67ed 100644
--- a/libstdc++-v3/testsuite/Makefile.am
+++ b/libstdc++-v3/testsuite/Makefile.am
@@ -50,15 +50,6 @@ libv3test_a_SOURCES = \
testsuite_allocator.cc \
testsuite_hooks.cc
-## Build support utilities.
-if GLIBCXX_TEST_ABI
-noinst_PROGRAMS = abi_check
-else
-noinst_PROGRAMS =
-endif
-abi_check_SOURCES = abi_check.cc
-abi_check_DEPENDENCIES = libv3test.a
-
all-local: stamp_wchar stamp_thread
# Enable wchar_t tests if capable.
@@ -104,6 +95,7 @@ site.exp: Makefile
@echo 'set target_triplet $(target_triplet)' >>site.tmp
@echo 'set target_triplet $(target_triplet)' >>site.tmp
@echo 'set libiconv "$(LIBICONV)"' >>site.tmp
+ @echo 'set baseline_file "$(baseline_file)"' >> site.tmp
@echo '## All variables above are generated by configure. Do Not Edit ##' >>site.tmp
@test ! -f site.exp || \
sed '1,/^## All variables above are.*##/ d' site.exp >> site.tmp
@@ -141,19 +133,10 @@ new-abi-baseline:
if GLIBCXX_TEST_ABI
# Use 'new-abi-baseline' to create an initial symbol file. Then run
# 'check-abi' to test for changes against that file.
-check-abi: abi_check baseline_symbols current_symbols.txt
- -@./abi_check --check ./current_symbols.txt ${baseline_file} \
- 2>&1 | tee libstdc++-abi.sum
- -@cp libstdc++-abi.sum libstdc++-abi.log
-
-check-abi-verbose: abi_check baseline_symbols current_symbols.txt
- -@./abi_check --check-verbose ./current_symbols.txt ${baseline_file} \
- 2>&1 | tee libstdc++-abi.sum
- -@cp libstdc++-abi.sum libstdc++-abi.log
-
+check-abi: baseline_symbols current_symbols.txt site.exp
+ -@runtest --tool libstdc++ abi.exp
else
check-abi:
-check-abi-verbose:
endif