summaryrefslogtreecommitdiff
path: root/libstdc++-v3/testsuite/Makefile.am
diff options
context:
space:
mode:
authorbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2004-10-06 22:12:34 +0000
committerbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2004-10-06 22:12:34 +0000
commitc37e7a9d014bc482424c4068fdd5944d023c57e9 (patch)
tree09d00f21fa64925e280dcf8b8337f681a42ec84f /libstdc++-v3/testsuite/Makefile.am
parent44be9f6ef17c4c8b6e09d528c9c60d6632af1eda (diff)
downloadgcc-c37e7a9d014bc482424c4068fdd5944d023c57e9.tar.gz
2004-10-06 Benjamin Kosnik <bkoz@redhat.com>
* acinclude.m4 (GLIBCXX_ENABLE_THREADS): Set enable_thread. (GLIBCXX_CONFIGURE_TESTSUITE): Use it. * configure: Regenerated. * testsuite/Makefile.am (CLEANFILES): Add TEST for check-performance executables. (stamp_thread): New. (all-local): Use it. * testsuite/Makefile.in: Regenerate. * scripts/create_testsuite_files: Filter thread tests. * testsuite/thread/pthread1.cc: Remove macro conditionals: this file will only be run by thread enabled configurations. * testsuite/thread/pthread7-rope.cc: Same, add rope_type typedef. * testsuite/thread/pthread6.cc: Same. * testsuite/thread/pthread5.cc: Same. * testsuite/thread/pthread4.cc: Same. * testsuite/thread/pthread3.cc: Same. * testsuite/thread/pthread2.cc: Same. * testsuite/ext/mt_allocator/instantiate.cc: Add in __GTHREADS guard. * testsuite/ext/mt_allocator/deallocate_global-1.cc: Move to... * testsuite/ext/mt_allocator/deallocate_global_thread-1.cc: ...here. * testsuite/ext/mt_allocator/deallocate_global-3.cc: Move to... * testsuite/ext/mt_allocator/deallocate_global_thread-3.cc: ...here. * testsuite/ext/mt_allocator/deallocate_local-1.cc: Move to... * testsuite/ext/mt_allocator/deallocate_local_thread-1.cc: ...here. * testsuite/ext/mt_allocator/deallocate_local-3.cc: Move to... * testsuite/ext/mt_allocator/deallocate_local_thread-3.cc: ...here. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@88628 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/testsuite/Makefile.am')
-rw-r--r--libstdc++-v3/testsuite/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/libstdc++-v3/testsuite/Makefile.am b/libstdc++-v3/testsuite/Makefile.am
index 9e11ac30ae9..a003497ecaf 100644
--- a/libstdc++-v3/testsuite/Makefile.am
+++ b/libstdc++-v3/testsuite/Makefile.am
@@ -57,7 +57,7 @@ endif
abi_check_SOURCES = abi_check.cc
abi_check_DEPENDENCIES = libv3test.a
-all-local: stamp_wchar testsuite_files
+all-local: stamp_wchar stamp_thread testsuite_files
# Enable wchar_t tests if capable.
if GLIBCXX_TEST_WCHAR_T
@@ -67,6 +67,14 @@ else
stamp_wchar:
endif
+# Enable thread tests if capable.
+if GLIBCXX_TEST_THREAD
+stamp_thread:
+ touch testsuite_thread
+else
+stamp_thread:
+endif
+
# Generated lists of files to run. All of these names are valid make
# targets, if you wish to generate a list manually.
lists_of_files = \
@@ -183,4 +191,4 @@ check-script check-script-install check-performance
# By adding these files here, automake will remove them for 'make clean'
CLEANFILES = *.txt *.tst *.exe core* filebuf_* tmp* ostream_* *.log *.sum \
- testsuite_* site.exp abi_check baseline_symbols
+ testsuite_* site.exp abi_check baseline_symbols *TEST*