summaryrefslogtreecommitdiff
path: root/libstdc++-v3/testsuite/Makefile.am
diff options
context:
space:
mode:
authorbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2005-04-07 04:16:26 +0000
committerbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2005-04-07 04:16:26 +0000
commit4f67a81c110abb352673685b1342555a167ab315 (patch)
tree0a8b72f68f7541959d5d1339c96727feefd86e9f /libstdc++-v3/testsuite/Makefile.am
parent05b9230fdf5296cea46d8dc159ba8ed1189787f9 (diff)
downloadgcc-4f67a81c110abb352673685b1342555a167ab315.tar.gz
2005-04-06 Benjamin Kosnik <bkoz@redhat.com>
* docs/html/test.html: Update. * testsuite/printnow.c: Remove. * scripts/check_survey.in: Remove. * testsuite/abi_check.cc: To... * testuite/testsuite_abi_check.cc: ...here. * testsuite/libstdc++-abi/abi.exp: Change abi_check.cc to testsuite_abi_check.cc. * testsuite/testsuite_hooks.h: Move character related bits to... * testsuite/testsuite_character.h: ...here. * testsuite/testsuite_character.cc: ... and here. * testsuite/21_strings/basic_string/inserters_extractors/pod/ 10081-in.cc: Use testsuite_character.h. * testsuite/21_strings/basic_string/inserters_extractors/pod/ 10081-out.cc: Same. * testsuite/22_locale/numpunct/members/pod/1.cc: Same. * testsuite/22_locale/numpunct/members/pod/2.cc: Same. * testsuite/27_io/basic_filebuf/2.cc: Same. * testsuite/27_io/basic_fstream/2.cc: Same. * testsuite/27_io/basic_istream/2.cc: Same. * testsuite/27_io/basic_istream/extractors_arithmetic/pod/ 3983-1.cc: Same. * testsuite/27_io/basic_istream/extractors_character/char/ 9826.cc: Same. * testsuite/27_io/basic_istream/extractors_character/pod/ 3983-2.cc: Same. * testsuite/27_io/basic_istream/extractors_other/pod/3983-3.cc: Same. * testsuite/27_io/basic_istream/sentry/pod/1.cc: Same. * testsuite/27_io/basic_ostream/2.cc: Same. * testsuite/27_io/basic_ostream/sentry/pod/1.cc: Same. * testsuite/27_io/basic_streambuf/2.cc: Same. * testsuite/27_io/basic_stringbuf/2.cc: Same. * testsuite/27_io/basic_stringbuf/4.cc: Same. * testsuite/27_io/basic_stringstream/2.cc: Same. * testsuite/27_io/fpos/1.cc: Same. * testsuite/ext/mt_allocator/tune-1.cc: Same. * testsuite/ext/mt_allocator/tune-2.cc: Same. * testsuite/ext/stdio_filebuf/char/1.cc: Same. * testsuite/lib/libstdc++.exp (v3-build_support): Add testsuite_character.cc. * testsuite/Makefile.am (libv3test_a_SOURCES): Add testsuite_character.cc. * testsuite/Makefile.in: Regenerate. * configure.ac: Remove use of check_survey. * configure: Regenerate. * testsuite/Makefile.am: Remove check-script and check-script-install rules. * testsuite/Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@97772 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/testsuite/Makefile.am')
-rw-r--r--libstdc++-v3/testsuite/Makefile.am46
1 files changed, 17 insertions, 29 deletions
diff --git a/libstdc++-v3/testsuite/Makefile.am b/libstdc++-v3/testsuite/Makefile.am
index 090dc3df0a1..fa013b6774a 100644
--- a/libstdc++-v3/testsuite/Makefile.am
+++ b/libstdc++-v3/testsuite/Makefile.am
@@ -1,6 +1,6 @@
## Makefile for the testsuite subdirectory of the GNU C++ Standard library.
##
-## Copyright (C) 2001, 2002, 2003 Free Software Foundation, Inc.
+## Copyright (C) 2001, 2002, 2003, 2005 Free Software Foundation, Inc.
##
## This file is part of the libstdc++ version 3 distribution.
## Process this file with automake to produce Makefile.in.
@@ -48,6 +48,7 @@ noinst_LIBRARIES = libv3test.a
libv3test_a_SOURCES = \
testsuite_abi.cc \
testsuite_allocator.cc \
+ testsuite_character.cc \
testsuite_hooks.cc
all-local: stamp_wchar stamp_thread
@@ -75,6 +76,10 @@ lists_of_files = \
testsuite_files_interactive \
testsuite_files_performance
+# This rule generates all of the testsuite_files* lists at once.
+${lists_of_files}:
+ ${glibcxx_srcdir}/scripts/create_testsuite_files \
+ ${glibcxx_srcdir}/testsuite `${PWD_COMMAND}`
# We need more things in site.exp, but automake completely controls the
# creation of that file; there's no way to append to it without messing up
@@ -103,6 +108,7 @@ site.exp: Makefile
@test ! -f site.exp || mv site.exp site.bak
@mv site.tmp site.exp
+
baseline_file = ${baseline_dir}/baseline_symbols.txt
extract_symvers = $(glibcxx_srcdir)/scripts/extract_symvers
@@ -133,20 +139,14 @@ else
check-abi:
endif
-
-# These two special 'check-script' rules use the bash script
-# 'check_survey' to do testing. This script is not as portable as the
-# dejagnu test harness, and is thus off by default. It does produce
-# interesting output however, including various performance analysis
-# items like compile time, execution time, and binary size.
-survey_script = ${glibcxx_builddir}/scripts/check_survey
-check-script: ${survey_script}
- -@(chmod + ${survey_script}; \
- ${survey_script} 0)
-
-check-script-install: ${survey_script}
- -@(chmod + ${survey_script}; \
- ${survey_script} 0)
+# Runs the testsuite, but in compile only mode.
+# Can be used to test sources with non-GNU FE's at various warning
+# levels and for checking compile time across releases.
+# See script.
+compile_script=${glibcxx_srcdir}/scripts/check_compile
+check-compile: testsuite_files ${compile_script}
+ -@(chmod + ${compile_script}; \
+ ${compile_script} ${glibcxx_srcdir} ${glibcxx_builddir})
# Runs the testsuite/performance tests.
@@ -158,21 +158,9 @@ check-performance: testsuite_files_performance ${performance_script}
-@(chmod + ${performance_script}; \
${performance_script} ${glibcxx_srcdir} ${glibcxx_builddir})
-# Runs the testsuite, but in compile only mode, and times it.
-# See script.
-compile_script=${glibcxx_srcdir}/scripts/check_compile
-check-compile: testsuite_files ${compile_script}
- -@(chmod + ${compile_script}; \
- ${compile_script} ${glibcxx_srcdir} ${glibcxx_builddir})
-
-# This rule generates all of the testsuite_files* lists at once.
-${lists_of_files}:
- ${glibcxx_srcdir}/scripts/create_testsuite_files \
- ${glibcxx_srcdir}/testsuite `${PWD_COMMAND}`
-
-.PHONY: baseline_symbols new-abi-baseline check-abi check-abi-verbose \
-check-script check-script-install check-performance
+.PHONY: baseline_symbols new-abi-baseline \
+ check-abi check-compile check-performance
# By adding these files here, automake will remove them for 'make clean'
CLEANFILES = *.txt *.tst *.exe core* filebuf_* tmp* ostream_* *.log *.sum \