summaryrefslogtreecommitdiff
path: root/libstdc++-v3/include/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Kosnik <bkoz@redhat.com>2003-03-04 05:23:56 +0000
committerBenjamin Kosnik <bkoz@gcc.gnu.org>2003-03-04 05:23:56 +0000
commit3a15abf155a41f2b94b7ccbdaaee6e0fecc9bf62 (patch)
tree378588752d090e9072ea15a30f3370defe91369e /libstdc++-v3/include/Makefile.am
parent767440a2db803feb263b444427753280852beaa6 (diff)
downloadgcc-3a15abf155a41f2b94b7ccbdaaee6e0fecc9bf62.tar.gz
abi_check.cc (report_symbol_info): Add version info.
2003-03-03 Benjamin Kosnik <bkoz@redhat.com> * testsuite/abi_check.cc (report_symbol_info): Add version info. * config/linker-map.gnu: Hide more stuff. * include/Makefile.am: Cleanups. * include/Makefile.in: Regenerate. From-SVN: r63764
Diffstat (limited to 'libstdc++-v3/include/Makefile.am')
-rw-r--r--libstdc++-v3/include/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/libstdc++-v3/include/Makefile.am b/libstdc++-v3/include/Makefile.am
index 526bbb0f1dd..cfa081f82f6 100644
--- a/libstdc++-v3/include/Makefile.am
+++ b/libstdc++-v3/include/Makefile.am
@@ -343,7 +343,7 @@ thread_target_headers = \
# CLEANFILES and all-local are kept up-to-date.
allstamps = \
stamp-std stamp-bits stamp-c_base stamp-c_compatibility \
- stamp-backward stamp-ext stamp-target
+ stamp-backward stamp-ext stamp-target stamp-std-precompile
# Here are the rules for building the headers
all-local: ${target_builddir}/c++config.h ${thread_target_headers} ${allstamps}
@@ -362,8 +362,9 @@ stamp-std: ${std_headers}
echo `date` > stamp-std ;\
fi
-stamp-std-precompile: stamp-std
+stamp-std-precompile: stamp-std ${target_builddir}/c++config.h
for h in ${std_headers_rename}; do \
+ echo "generating $$h.pch..."; \
$(CXX) -Winvalid-pch -x c++-header $(INCLUDES) $${h}; \
done; \
echo `date` > stamp-std-precompile