summaryrefslogtreecommitdiff
path: root/libstdc++-v3/configure.ac
diff options
context:
space:
mode:
authorpaolo <paolo@138bc75d-0d04-0410-961f-82ee72b054a4>2006-06-09 23:37:28 +0000
committerpaolo <paolo@138bc75d-0d04-0410-961f-82ee72b054a4>2006-06-09 23:37:28 +0000
commit61edee22190ce29f51e9c58675732c732b37a7f7 (patch)
treeb0b35b54857630cba67404df1c6d5bb2c1d445fe /libstdc++-v3/configure.ac
parentd77f260f5a8da7df9137839267784a357479b54a (diff)
downloadgcc-61edee22190ce29f51e9c58675732c732b37a7f7.tar.gz
2006-06-09 Paolo Carlini <pcarlini@suse.de>
* acinclude.m4 ([GLIBCXX_CHECK_RANDOM_TR1]): New, check for the availability of "/dev/random" and "/dev/urandom". * configure.ac: Use it. * include/tr1/random (random_device): Implement, a fall-back for systems not providing "/dev/random" and "/dev/urandom" included. * testsuite/tr1/5_numerical_facilities/random/random_device/ cons/default.cc: New. * testsuite/tr1/5_numerical_facilities/random/random_device/ cons/token.cc: Likewise. * testsuite/tr1/5_numerical_facilities/random/random_device/ requirements/typedefs.cc: Likewise. * config.h.in: Regenerate. * configure: Likewise. * testsuite/tr1/5_numerical_facilities/random/mersenne_twister/ cons/gen1.cc: Minor tweak, add bool test. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@114529 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/configure.ac')
-rw-r--r--libstdc++-v3/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/libstdc++-v3/configure.ac b/libstdc++-v3/configure.ac
index 45dd410ae0c..88018c3d57b 100644
--- a/libstdc++-v3/configure.ac
+++ b/libstdc++-v3/configure.ac
@@ -160,6 +160,9 @@ if $GLIBCXX_IS_NATIVE; then
# For C99 support to TR1.
GLIBCXX_CHECK_C99_TR1
+ # For dev/random and dev/urandom for TR1.
+ GLIBCXX_CHECK_RANDOM_TR1
+
# For TLS support.
GCC_CHECK_TLS