summaryrefslogtreecommitdiff
path: root/libstdc++-v3/configure.ac
diff options
context:
space:
mode:
authorpme <pme@138bc75d-0d04-0410-961f-82ee72b054a4>2003-08-27 19:06:56 +0000
committerpme <pme@138bc75d-0d04-0410-961f-82ee72b054a4>2003-08-27 19:06:56 +0000
commit11764568741aa1f18cf60ee6099b73a922e736c4 (patch)
treed38037daf02cdd90f73e292b4bafe5c70a210f8a /libstdc++-v3/configure.ac
parentc2c1332a4a09d25fd02fcef5c34080763437080b (diff)
downloadgcc-11764568741aa1f18cf60ee6099b73a922e736c4.tar.gz
2003-08-27 Phil Edwards <pme@gcc.gnu.org>
* acinclude.m4 (GLIBCXX_CONDITIONAL): New macro. Wrap AM_CONDITIONAL. Replace all calls to AM_CONDITIONAL with this one. (GLIBCXX_ENABLE_HOSTED): New macro, sets new variable is_hosted, used elsewhere in this file. (GLIBCXX_EVALUATE_CONDITIONALS): New macro... * configure.ac: ...called here to expand all conditionals. * Makefile.am: Conditionalize SUBDIRS on GLIBCXX_HOSTED. * include/Makefile.am: Remove redundant gxx_include_dir assignment. (install-freestanding-headers): New target, a subset of install-headers. Conditionalize install-data-local on GLIBCXX_HOSTED. * aclocal.m4, configure, Makefile.in, include/Makefile.in, libmath/Makefile.in, libsupc++/Makefile.in, po/Makefile.in, src/Makefile.in, testsuite/Makefile.in: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@70854 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/configure.ac')
-rw-r--r--libstdc++-v3/configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/libstdc++-v3/configure.ac b/libstdc++-v3/configure.ac
index 326b22f19e6..d10d38144e5 100644
--- a/libstdc++-v3/configure.ac
+++ b/libstdc++-v3/configure.ac
@@ -70,10 +70,15 @@ AC_SUBST(enable_shared)
AC_SUBST(enable_static)
#AC_MSG_NOTICE([====== Finished libtool configuration]) ; sleep 10
+# Possibly disable most of the library.
+## XXX Consider skipping unncessary tests altogether in this case, rather
+## than just ignoring the results. Faster /and/ more correct, win win.
+GLIBCXX_ENABLE_HOSTED
+
# Check for support bits and g++ features that don't require linking.
GLIBCXX_ENABLE_SJLJ_EXCEPTIONS
GLIBCXX_ENABLE_LIBUNWIND_EXCEPTIONS
-GLIBCXX_ENABLE_PCH([yes])
+GLIBCXX_ENABLE_PCH($is_hosted)
# Enable all the variable C++ runtime options.
# NB: C_MBCHAR must come early.
@@ -266,6 +271,7 @@ AC_SUBST(OS_INC_SRCDIR)
#AM_CONDITIONAL(CANADIAN, test $CANADIAN = yes)
# from GLIBCXX_CHECK_COMPLEX_MATH_SUPPORT:
#AM_CONDITIONAL(GLIBCXX_BUILD_LIBMATH, test $need_libmath = yes)
+GLIBCXX_EVALUATE_CONDITIONALS
AC_CACHE_SAVE