summaryrefslogtreecommitdiff
path: root/libstdc++-v3/Makefile.am
diff options
context:
space:
mode:
authorgdr <gdr@138bc75d-0d04-0410-961f-82ee72b054a4>2001-01-25 04:09:22 +0000
committergdr <gdr@138bc75d-0d04-0410-961f-82ee72b054a4>2001-01-25 04:09:22 +0000
commit0f3f02b41802e8011822049ddc7fc06f80bd0e92 (patch)
tree7d88af4123c93afacac6a7306051c13edc4cb5b7 /libstdc++-v3/Makefile.am
parent132d0199d4430519db22b9e7f2eb9375983ca3a4 (diff)
downloadgcc-0f3f02b41802e8011822049ddc7fc06f80bd0e92.tar.gz
* testsuite/27_io/*.cc: Remove explicit reference to 'testsuite/'
in testcases. Prepare for the DejaGnu based framework. * mkcheck.in: Adjust call to tests_flags. Don't mmkdir testsuite directory -- it is now mkcheck working directory. * tests_flags.in: Remove reference to $(top_srcdir). Use ${SRC_DIR} instead. * Makefile.am (check, check-install): Change mkcheck invocation logic. * Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@39255 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/Makefile.am')
-rw-r--r--libstdc++-v3/Makefile.am18
1 files changed, 11 insertions, 7 deletions
diff --git a/libstdc++-v3/Makefile.am b/libstdc++-v3/Makefile.am
index 0c5c09f2b54..aab3dc155b3 100644
--- a/libstdc++-v3/Makefile.am
+++ b/libstdc++-v3/Makefile.am
@@ -26,17 +26,21 @@ MAINT_CHARSET = latin1
SUBDIRS = libio libmath libsupc++ src
-
-# Use $(blddir) instead of $(top_builddir) for arguments to "mkcheck"
+# Use $${builddir} instead of $(top_builddir) for arguments to "mkcheck"
# because then the paths will be full pathnames, not relative
# pathnames. (-Wl,--rpath seems to like this better.)
-check: $(top_builddir)/mkcheck
- chmod +x $(top_builddir)/mkcheck
- $(top_builddir)/mkcheck 0 `pwd` $(top_srcdir)
+check: $(top_builddir)/mkcheck
+ -(chmod + $(top_builddir)/mkcheck; \
+ srcdir=`cd $(top_srcdir); pwd`; builddir=`pwd`; \
+ test -d testsuite || (mkdir testsuite; chmod u+w testsuite); \
+ cd testsuite; $${builddir}/mkcheck 0 $${builddir} $${srcdir})
check-install: $(top_builddir)/mkcheck
- chmod +x $(top_builddir)/mkcheck
- $(top_builddir)/mkcheck 1 `pwd` $(top_srcdir) $(prefix)
+ -(chmod + $(top_builddir)/mkcheck; \
+ srcdir=`cd $(top_srcdir); pwd`; builddir=`pwd`; \
+ test -d testsuite || (mkdir testsuite; chmod u+w testsuite); \
+ cd testsuite; \
+ $${builddir}/mkcheck 1 $${builddir} $${srcdir} $(prefix))
# Multilib support.
MAKEOVERRIDES=