summaryrefslogtreecommitdiff
path: root/libstdc++-v3/Makefile.am
diff options
context:
space:
mode:
authorbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2000-10-17 08:25:08 +0000
committerbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2000-10-17 08:25:08 +0000
commitaf7db8cb22256d2ba4039fe9ef231702f4bb92c2 (patch)
treeca758d85d8aa5ae51afe442a86f12910b08488c6 /libstdc++-v3/Makefile.am
parent1b9a993065e958d89af34d3abb677e1d3c468236 (diff)
downloadgcc-af7db8cb22256d2ba4039fe9ef231702f4bb92c2.tar.gz
2000-10-16 Benjamin Kosnik <bkoz@gnu.org>
Shadow headers would work if libsupc++ was strict about namespaces. This only possible if g++ maps std::size_t -> size_t. (Hint hint.) * include/c_std/assert.h: Add guards. * include/c_std/bits/std_climits.h: Correct typo. * include/c_std/ctype.h: Remove #error. * libio/libioP.h: Break up extern "C" bits around includes. * libio/libio.h: Only include C headers, or else _C_legacy namespaces will be nested. * libio/libioP.h: Same here. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@36900 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/Makefile.am')
-rw-r--r--libstdc++-v3/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libstdc++-v3/Makefile.am b/libstdc++-v3/Makefile.am
index b32a151cd8b..0c5c09f2b54 100644
--- a/libstdc++-v3/Makefile.am
+++ b/libstdc++-v3/Makefile.am
@@ -121,4 +121,4 @@ AM_MAKEFLAGS = \
"NM_FOR_BUILD=$(NM_FOR_BUILD)" \
"NM_FOR_TARGET=$(NM_FOR_TARGET)" \
"DESTDIR=$(DESTDIR)" \
- "WERROR=$(WERROR)" \ No newline at end of file
+ "WERROR=$(WERROR)"