summaryrefslogtreecommitdiff
path: root/libstdc++-v3/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Kosnik <bkoz@gcc.gnu.org>2000-10-09 08:55:06 +0000
committerBenjamin Kosnik <bkoz@gcc.gnu.org>2000-10-09 08:55:06 +0000
commit0b8e0cf35e4c2c88c0c7889c9632d7894dce60af (patch)
treee4bb97dafe0d7ffcf8453f17aa28cd9458c7c4df /libstdc++-v3/Makefile.am
parentb5c47c68faede5ccceca1fa5fda59a196e7e6f1d (diff)
downloadgcc-0b8e0cf35e4c2c88c0c7889c9632d7894dce60af.tar.gz
configopts.html: Edit.
2000-10-10 Benjamin Kosnik <bkoz@purist.soma.redhat.com> * docs/configopts.html: Edit. * libio/Makefile.am (INCLUDES): Remove duplicates, simplify. * libio/Makefile.in: Regenerate. * libmath/Makefile.am (INCLUDES): Remove duplicates, simplify. * libmath/Makefile.in: Regenerate. * libsupc++/Makefile.am (INCLUDES): Remove duplicate. * libsupc++/Makefile.in: Regenerate. * Makefile.am (AM_MAKEFLAGS): Add GLIBCPP_INCLUDES, TOPLEVEL_INCLUDES, LIBMATH_INCLUDES, LIBIO_INCLUDES, CSHADOW_INCLUDES up here. * Makefile.in: Regenerate. * src/Makefile.am (CSHADOW_INCLUDES): Add include/c_std, include/c for shadow headers. (myinstallheaders): Change glibcpp_includedir to GLIBCPP_INCLUDES. Move GLIBCPP_INCLUDES, TOPLEVEL_INCLUDES, LIBMATH_INCLUDES, LIBIO_INCLUDES, CSHADOW_INCLUDES up Makefile hierarchy. * src/Makefile.in: Regenerate. * include/c: New directory. * include/c/bits/(std_cassert.h, std_cctype.h, std_cerrno.h, std_cfloat.h, std_climits.h, std_clocale.h, std_cmath.h, std_csetjmp.h, std_csignal.h, std_cstdarg.h, std_cstddef.h, std_cstdio.h, std_cstdlib.h, std_cstring.h, std_ctime.h, std_cwchar.h, std_cwctype.h): Add, moving from... * include/bits: ...here. * include/c_std: New directory. * include/c_std/bits/*: Populate from... * shadow: ...here. Remove directory. From-SVN: r36805
Diffstat (limited to 'libstdc++-v3/Makefile.am')
-rw-r--r--libstdc++-v3/Makefile.am38
1 files changed, 32 insertions, 6 deletions
diff --git a/libstdc++-v3/Makefile.am b/libstdc++-v3/Makefile.am
index a4362ace6e6..7803b79f4c2 100644
--- a/libstdc++-v3/Makefile.am
+++ b/libstdc++-v3/Makefile.am
@@ -52,6 +52,32 @@ CONFIG_CXXFLAGS = \
@SECTION_FLAGS@ @CSHADOWFLAGS@ @DEBUG_FLAGS@
+# Root level of the include sources.
+GLIBCPP_INCLUDES = $(top_srcdir)/include
+
+# Passed down for cross compilers, canadian crosses.
+TOPLEVEL_INCLUDES = -I$(includedir)
+
+LIBMATH_INCLUDES = -I$(top_srcdir)/libmath
+
+if GLIBCPP_NEED_LIBIO
+LIBIO_INCLUDES = \
+ -I$(top_builddir)/libio -I$(top_srcdir)/libio
+else
+LIBIO_INCLUDES = -I$(top_srcdir)/libio
+endif
+
+# XXX may need to add this in later to enabled shadow header includes
+# -I$(top_builddir)/cshadow
+if GLIBCPP_USE_CSHADOW
+CSHADOW_INCLUDES = \
+ -I$(GLIBCPP_INCLUDES)/std -I$(GLIBCPP_INCLUDES)/c_std
+else
+CSHADOW_INCLUDES = \
+ -I$(GLIBCPP_INCLUDES)/std -I$(GLIBCPP_INCLUDES)/c
+endif
+
+
# Use $(blddir) instead of $(top_builddir) for arguments to "mkcheck"
# because then the paths will be full pathnames, not relative
# pathnames. (-Wl,--rpath seems to like this better.)
@@ -149,10 +175,10 @@ AM_MAKEFLAGS = \
"WERROR=$(WERROR)" \
"OPTIMIZE_CXXFLAGS=$(OPTIMIZE_CXXFLAGS)" \
"WARN_CXXFLAGS=$(WARN_CXXFLAGS)" \
- "CONFIG_CXXFLAGS=$(CONFIG_CXXFLAGS)"
-
-
-
-
-
+ "CONFIG_CXXFLAGS=$(CONFIG_CXXFLAGS)" \
+ "GLIBCPP_INCLUDES=$(GLIBCPP_INCLUDES)" \
+ "TOPLEVEL_INCLUDES=$(TOPLEVEL_INCLUDES)" \
+ "LIBMATH_INCLUDES=$(LIBMATH_INCLUDES)" \
+ "LIBIO_INCLUDES=$(LIBIO_INCLUDES)" \
+ "CSHADOW_INCLUDES=$(CSHADOW_INCLUDES)"