summaryrefslogtreecommitdiff
path: root/libobjc/configure.in
diff options
context:
space:
mode:
authorlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>1999-01-05 00:40:22 +0000
committerlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>1999-01-05 00:40:22 +0000
commit5ed09c3bef070a2eebeee04fd8ef78feb60f9190 (patch)
tree5bbac729dd9eebacf9be5667828794c2cae844ec /libobjc/configure.in
parent5f8a7c119aff0c3fa505ba617b2e2f6bb534cb2b (diff)
downloadgcc-5ed09c3bef070a2eebeee04fd8ef78feb60f9190.tar.gz
* configure.in (thread_file): Correct and simplify code to find
the thread file. * configure: Rebuilt. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@24494 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libobjc/configure.in')
-rw-r--r--libobjc/configure.in11
1 files changed, 2 insertions, 9 deletions
diff --git a/libobjc/configure.in b/libobjc/configure.in
index 73bdd0d49be..061501b642c 100644
--- a/libobjc/configure.in
+++ b/libobjc/configure.in
@@ -90,17 +90,10 @@ AC_HEADER_STDC
# Determine the name of the GCC thread file.
-dir=`pwd`
-if test x"${with_multisubdir}" = "x" ; then
- gccobjdir=`echo $dir/../../gcc`
-else
- gccobjdir=`echo $dir | sed -e s:${with_multisubdir}::`/../../gcc
-fi
-
AC_CACHE_CHECK([for thread file],objc_cv_thread_file,
-[if test -f $gccobjdir/Makefile
+[if test -f "$r"/gcc/Makefile
then
- objc_cv_thread_file=`grep \^GCC_THREAD_FILE $gccobjdir/Makefile | awk -F= '{ print $2 }'`
+ objc_cv_thread_file=`grep \^GCC_THREAD_FILE "$r"/gcc/Makefile | awk -F= '{ print $2 }'`
else
AC_MSG_ERROR([not found])
fi])