summaryrefslogtreecommitdiff
path: root/libmudflap/configure.ac
diff options
context:
space:
mode:
authorwilson <wilson@138bc75d-0d04-0410-961f-82ee72b054a4>2005-10-04 23:54:38 +0000
committerwilson <wilson@138bc75d-0d04-0410-961f-82ee72b054a4>2005-10-04 23:54:38 +0000
commitf7747728204a312498429c0279df0fa81703eaae (patch)
treef0f593f2e0a946e2d96680db1b0b63b5df5f71d0 /libmudflap/configure.ac
parenta840dd14bb69555e7c476de26040090187a013d3 (diff)
downloadgcc-f7747728204a312498429c0279df0fa81703eaae.tar.gz
This avoids small data/gp reloc overflow errors.
* configure.ac (mudflap_cv_entry_point): Use quadrigraphs to declare $name as array of characters with unknown bound. Also store into the array. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@104964 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libmudflap/configure.ac')
-rw-r--r--libmudflap/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/libmudflap/configure.ac b/libmudflap/configure.ac
index 039ff4e5f5c..51ed6e3bf4a 100644
--- a/libmudflap/configure.ac
+++ b/libmudflap/configure.ac
@@ -241,7 +241,7 @@ AC_SUBST(SECTION_FLAGS)
AC_CACHE_CHECK([for the name of the symbol used for the entry point],
[mudflap_cv_entry_point], [
for name in _start __start unknown; do
- AC_LINK_IFELSE([AC_LANG_PROGRAM([extern char $name;], [$name = 0;])],
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([extern char $name@<:@@:>@;], [$name@<:@0@:>@ = 0;])],
[break])
done
mudflap_cv_entry_point="$name"])