summaryrefslogtreecommitdiff
path: root/libmudflap/Makefile.am
diff options
context:
space:
mode:
authorfche <fche@138bc75d-0d04-0410-961f-82ee72b054a4>2004-06-24 21:12:18 +0000
committerfche <fche@138bc75d-0d04-0410-961f-82ee72b054a4>2004-06-24 21:12:18 +0000
commit9a1a84ca103b211b3b5c02d9618752a2a57d6201 (patch)
treeb11f74e9117eab25751541c23cf9a481cd239e29 /libmudflap/Makefile.am
parenta95bd78053d406b8805a71771e8e686f7ebdeef4 (diff)
downloadgcc-9a1a84ca103b211b3b5c02d9618752a2a57d6201.tar.gz
2004-06-24 Frank Ch. Eigler <fche@redhat.com>
Adopt splay trees for object database. * Makefile.am: Copy splay-tree.* from libiberty. * Makefile.in, testsuite/Makefile.in: Regenerated. * mf-runtime.h.in (__mf_unregister): Add third parameter (type). * mf-hooks[123].c (*): Add new third parameter to mf_unregister. * mf-impl.h (BEGIN_PROTECT): Remove some trace text. * mf-runtime.c: Rewrite code dealing with object database to use libiberty splay trees. Remove tree liveness aging option. * testsuite/libmudflap.c/fail18-frag.c: Add volatile flag. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@83611 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libmudflap/Makefile.am')
-rw-r--r--libmudflap/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/libmudflap/Makefile.am b/libmudflap/Makefile.am
index 7bcaeb5db66..639db4218d4 100644
--- a/libmudflap/Makefile.am
+++ b/libmudflap/Makefile.am
@@ -20,18 +20,29 @@ endif
toolexeclib_LTLIBRARIES = libmudflap.la $(libmudflapth)
include_HEADERS = mf-runtime.h
+# Copy this out of libiberty's source tree, so it can be built here via libtool
+splay-tree.c:
+ rm -f $@
+ $(LN_S) $(srcdir)/../libiberty/splay-tree.c $@
+# Copy this so that top-level include/ does not have to be put into -I path
+splay-tree.h:
+ rm -f $@
+ $(LN_S) $(srcdir)/../include/splay-tree.h $@
+
libmudflap_la_SOURCES = \
mf-runtime.c \
mf-heuristics.c \
mf-hooks1.c \
mf-hooks2.c
+mf-runtime.lo: mf-runtime.c splay-tree.c splay-tree.h
libmudflap_la_LIBADD =
libmudflap_la_DEPENDENCIES = $(libmudflap_la_LIBADD)
clean-local:
rm -f pth/*.o pth/*.lo
+ rm -f splay-tree.c splay-tree.h
-pth/mf-runtime.lo: mf-runtime.c mf-runtime.h mf-impl.h
+pth/mf-runtime.lo: mf-runtime.c mf-runtime.h mf-impl.h splay-tree.c splay-tree.h
$(LTCOMPILE) -DLIBMUDFLAPTH -c $(srcdir)/mf-runtime.c -o $@
pth/mf-heuristics.lo: mf-heuristics.c mf-runtime.h mf-impl.h
$(LTCOMPILE) -DLIBMUDFLAPTH -c $(srcdir)/mf-heuristics.c -o $@