summaryrefslogtreecommitdiff
path: root/libjava/configure.in
diff options
context:
space:
mode:
authorgreen <green@138bc75d-0d04-0410-961f-82ee72b054a4>1999-10-15 06:07:41 +0000
committergreen <green@138bc75d-0d04-0410-961f-82ee72b054a4>1999-10-15 06:07:41 +0000
commitf5fddbf2d840fc50ed043ec01cd90a2bf489d23b (patch)
treebbd6554459daad973191b77a62d0237b045595f3 /libjava/configure.in
parenta597770e89f0bb82199dc77f99a5a1b720dc33da (diff)
downloadgcc-f5fddbf2d840fc50ed043ec01cd90a2bf489d23b.tar.gz
* libtool-version: Catch up by incrementing current.
* configure.host: Disable use of GCJ_PROPERTIES for mips-tx39. * configure, include/config.h.in: Rebuilt. * acconfig.h (DISABLE_GETENV_PROPERTIES): Undefine. * configure.in: Added --disable-getenv-properties and new define `DISABLE_GETENV_PROPERTIES'. * prims.cc (PROCESS_GCJ_PROPERTIES): Define. (next_property_key): New function. (next_property_value): New function. (process_gcj_properties): New function. (JvRunMain): Call process_gcj_properties. (_JvRunMain): Ditto. * java/lang/natSystem.cc (init_properties): Set properties defined in GCJ_PROPERTIES. Also add 1.2 style versioning properties. * include/java-props.h: New file. * java/lang/natSystem.cc (init_properties): Add new properties to conform with Java Product Versioning Specification. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@30007 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/configure.in')
-rw-r--r--libjava/configure.in16
1 files changed, 15 insertions, 1 deletions
diff --git a/libjava/configure.in b/libjava/configure.in
index e654fcdfec4..751a7630282 100644
--- a/libjava/configure.in
+++ b/libjava/configure.in
@@ -9,7 +9,7 @@ AC_CANONICAL_SYSTEM
dnl We use these options to decide which functions to include.
AC_ARG_WITH(target-subdir,
[ --with-target-subdir=SUBDIR
- configuring in a subdirectory])
+ configuring in a subdirectory])
AC_ARG_WITH(cross-host,
[ --with-cross-host=HOST configuring with a cross compiler])
@@ -36,6 +36,20 @@ AC_ARG_ENABLE(fast-character,
# Nothing
, AC_DEFINE(COMPACT_CHARACTER))
+dnl Should the runtime set system properties by examining the
+dnl environment variable GCJ_PROPERTIES?
+AC_ARG_ENABLE(getenv-properties,
+[ --disable-getenv-properties
+ don't set system properties from GCJ_PROPERTIES])
+
+dnl Whether GCJ_PROPERTIES is used depends on the target.
+if test -n "$enable_getenv_properties"; then
+ enable_getenv_properties=${enable_getenv_properties_default-yes}
+fi
+if test "$enable_getenv_properties" = no; then
+ AC_DEFINE(DISABLE_GETENV_PROPERTIES)
+fi
+
dnl See if the user has requested runtime debugging.
AC_ARG_ENABLE(libgcj-debug,
[ --enable-libgcj-debug enable runtime debugging code],