summaryrefslogtreecommitdiff
path: root/libjava/configure.ac
diff options
context:
space:
mode:
authoraph <aph@138bc75d-0d04-0410-961f-82ee72b054a4>2009-08-17 17:30:10 +0000
committeraph <aph@138bc75d-0d04-0410-961f-82ee72b054a4>2009-08-17 17:30:10 +0000
commitd4704182ad38f6feadff54ede3a582427d76381f (patch)
tree81950d4c1adafada9fa63f8cc147db0c7b6daf2d /libjava/configure.ac
parent7d68087c2df5777a3c72b2cab265d1ce6ea7a01a (diff)
downloadgcc-d4704182ad38f6feadff54ede3a582427d76381f.tar.gz
2009-08-17 Andrew Haley <aph@redhat.com>
* Makefile.am (libgcj_bc_la_LIBADD): Delete. * libgcj.spec.in: (LIBGCJ_BC_SPEC): New spec. * configure.ac (LIBGCJ_BC_SPEC): New spec. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@150853 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/configure.ac')
-rw-r--r--libjava/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/libjava/configure.ac b/libjava/configure.ac
index 7dfb5c58923..2057bf3d6d6 100644
--- a/libjava/configure.ac
+++ b/libjava/configure.ac
@@ -1078,8 +1078,10 @@ AC_CONFIG_LINKS(sysdep/descriptor.h:$descriptor_h)
LIBGCJ_SPEC="%{s-bc-abi:} -lgcj"
if test "$use_libgcj_bc" = yes; then
LIBGCJ_SPEC="%{static|static-libgcj|!s-bc-abi:-lgcj;:-lgcj_bc}"
+ LIBGCJ_BC_SPEC="%{findirect-dispatch:-fPIC}"
fi
AC_SUBST(LIBGCJ_SPEC)
+AC_SUBST(LIBGCJ_BC_SPEC)
HASH_SYNC_SPEC=
# Hash synchronization is only useful with posix threads right now.