summaryrefslogtreecommitdiff
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
authortromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2006-04-04 00:30:05 +0000
committertromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2006-04-04 00:30:05 +0000
commitb0cb8c44603a6d2fd43fdab7c8a04d19ed5cd06e (patch)
treee7eff1dfe7f6d953e9d4f452f6d946837a9a4d07 /libjava/Makefile.am
parent8ab158f92d520df02d8d195fe404104420ee2def (diff)
downloadgcc-b0cb8c44603a6d2fd43fdab7c8a04d19ed5cd06e.tar.gz
fastjar
Removed libjava * Makefile.in: Rebuilt. * Makefile.am (ZIP): Removed. (libgcj-$(gcc_version).jar): Use $(JAR). (src.zip): Likewise. * configure: Rebuilt. * configure.ac: Check for jar. Removed code to set ZIP. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@112654 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am15
1 files changed, 6 insertions, 9 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index 4f663a0c9c5..3deaa7eb1e1 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -87,7 +87,6 @@ bin_SCRIPTS = addr2name.awk
##
GCJH = @GCJH@
-ZIP = @ZIP@
## The compiler with whatever flags we want for both -c and -C
## compiles.
@@ -322,10 +321,7 @@ $(propertyo_files): %.lo: classpath/resource/%
$(LTGCJCOMPILE) -o $@ -c $< -Wc,--resource,$(@:.lo=)
libgcj-$(gcc_version).jar:
- jardir=`dirname $(ZIP)`; \
- jardir=`cd $$jardir && pwd`; \
- jarname=`basename $(ZIP)`; \
- cd classpath/lib; $$jardir/$$jarname -cfM \
+ cd classpath/lib; $(JAR) -cfM \
../../libgcj-$(gcc_version).jar gnu java javax org
CLEANFILES = libgcj-$(gcc_version).jar \
@@ -883,9 +879,10 @@ src.zip:
echo $$file; \
done ); \
) | \
-## Many of the above circumlocutions are because ZIP will most likely
-## be a relative path to fastjar.
- $(ZIP) -cfM@ $$here/src.zip
+## Many of the above circumlocutions were because ZIP used to be a
+## relative path to fastjar. It didn't seem worthwhile to change the
+## code when we moved to an external jar.
+ $(JAR) -cfM@ $$here/src.zip
## Override GNU Classpath sources with libgcj replacements.
here=`pwd`; \
( \
@@ -897,7 +894,7 @@ src.zip:
echo $$file; \
done ); \
) | \
- $(ZIP) -ufM@ $$here/src.zip
+ $(JAR) -ufM@ $$here/src.zip
## We use a variable for this in case the user wants to override it.
sourcesdir = $(jardir)