summaryrefslogtreecommitdiff
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
authortromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2007-03-06 18:50:14 +0000
committertromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2007-03-06 18:50:14 +0000
commit4ea69e9efb4ab33b0ce910662afedbc496d319fa (patch)
treec5452f7e1270ef188ad20f0d8a167fa9e5ae542f /libjava/Makefile.am
parentae422aea7088fbe544a1547f91b95547f43b4509 (diff)
downloadgcc-4ea69e9efb4ab33b0ce910662afedbc496d319fa.tar.gz
libjava
* Makefile.in: Rebuilt. * Makefile.am (bin_PROGRAMS): Added gcjh. (gcjh_SOURCES, gcjh_LDFLAGS, gcjh_LINK, gcjh_LDADD, gcjh_DEPENDENCIES): New variables. libjava/classpath * tools/gnu/classpath/tools/javah/Main.java (getName): New method. (getParser): Now protected. Use getName. Add '-v' alias for --verbose. (postParse): New method. (run): Now protected. Use postParse. * tools/gnu/classpath/tools/javah/GcjhMain.java: New file. * tools/Makefile.in: Rebuilt. * tools/Makefile.am: Remove vm-tools.lst before creating it. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@122631 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index 42475b6a7c5..58ea100fdb5 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -72,7 +72,7 @@ db_pathtail = gcj-$(gcc_version)/$(db_name)
## For now, only on native systems. FIXME.
if NATIVE
bin_PROGRAMS = jv-convert gij grmic grmiregistry gcj-dbtool \
- gappletviewer gjarsigner gkeytool gjar gjavah gnative2ascii \
+ gappletviewer gjarsigner gkeytool gjar gcjh gjavah gnative2ascii \
gorbd grmid gserialver gtnameserv gc-analyze
## It is convenient to actually build and install the default database
@@ -757,6 +757,15 @@ gjavah_LDADD = -L$(here)/.libs libgcj-tools.la
gjavah_DEPENDENCIES = libgcj-tools.la
## This is a dummy definition.
+gcjh_SOURCES =
+gcjh_LDFLAGS = --main=gnu.classpath.tools.javah.GcjhMain \
+ -rpath $(toolexeclibdir) -shared-libgcc $(THREADLDFLAGS)
+gcjh_LINK = $(GCJLINK)
+## See jv_convert_LDADD.
+gcjh_LDADD = -L$(here)/.libs libgcj-tools.la
+gcjh_DEPENDENCIES = libgcj-tools.la
+
+## This is a dummy definition.
gnative2ascii_SOURCES =
gnative2ascii_LDFLAGS = --main=gnu.classpath.tools.native2ascii.Native2ASCII \
-rpath $(toolexeclibdir) -shared-libgcc $(THREADLDFLAGS)