summaryrefslogtreecommitdiff
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
authorgandalf <gandalf@138bc75d-0d04-0410-961f-82ee72b054a4>2009-03-03 17:03:51 +0000
committergandalf <gandalf@138bc75d-0d04-0410-961f-82ee72b054a4>2009-03-03 17:03:51 +0000
commit2e9edbc98892d32e8b79c31607e284beb6c00636 (patch)
tree60c3b065fa902e4b87279fbf3bfddb96226fa41a /libjava/Makefile.am
parent072866b64ffbe16bc34d0294c4b8bc9b4ec37ac3 (diff)
downloadgcc-2e9edbc98892d32e8b79c31607e284beb6c00636.tar.gz
Cleanup new JDK directory support in GCJ.
2009-03-03 Andrew John Hughes <ahughes@redhat.com> * Makefile.am: Remove dangling src.zip and javac symlinks. Fix java.security symlink to use toolexeclibdir as classpath/resource/Makefile.am does. * Makefile.in, * configure: Regenerated. * configure.ac: Drop hard-coded prefix, thus removing sdk_dir and making jre_dir="jre". Map x86_64 to amd64 as used by OpenJDK. * gcj/Makefile.in, * include/Makefile.in, * testsuite/Makefile.in: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@144576 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index 49685896878..c4746bfd854 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -586,7 +586,6 @@ if CREATE_JAVA_HOME
$(DESTDIR)$(SDK_BIN_DIR)/rmic; \
ln -sf $$RELATIVE/`echo gjavah | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'` \
$(DESTDIR)$(SDK_BIN_DIR)/javah; \
- ln -sf $$RELATIVE/ecj $(DESTDIR)$(SDK_BIN_DIR)/javac; \
ln -sf $$RELATIVE/`echo gappletviewer | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'` \
$(DESTDIR)$(SDK_BIN_DIR)/appletviewer; \
ln -sf $$RELATIVE/`echo gjarsigner | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'` \
@@ -638,7 +637,7 @@ if CREATE_JAVA_HOME
done; \
cd $$working_dir; \
$(mkinstalldirs) $(DESTDIR)$(JRE_LIB_DIR)/security; \
- RELATIVE=$$(relative $(DESTDIR)$(libdir)/security \
+ RELATIVE=$$(relative $(DESTDIR)$(toolexeclibdir)/security \
$(DESTDIR)$(JRE_LIB_DIR)/security); \
cd $(DESTDIR)$(JRE_LIB_DIR)/security; \
ln -sf $$RELATIVE/classpath.security java.security; \
@@ -684,9 +683,7 @@ if CREATE_JAVA_HOME
$(DESTDIR)$(SDK_INCLUDE_DIR)/linux/$$headername.h; \
done; \
RELATIVE=$$(relative $(DESTDIR)$(datadir)/java \
- $(DESTDIR)$(JVM_ROOT_DIR)/$(SDK_DIR)); \
- ln -sf $$RELATIVE/src-$(gcc_version).zip \
- $(DESTDIR)$(JVM_ROOT_DIR)/$(SDK_DIR)/src.zip;
+ $(DESTDIR)$(JVM_ROOT_DIR)/$(SDK_DIR));
endif
## ################################################################