summaryrefslogtreecommitdiff
path: root/libitm/Makefile.am
diff options
context:
space:
mode:
authorrth <rth@138bc75d-0d04-0410-961f-82ee72b054a4>2011-11-10 17:09:04 +0000
committerrth <rth@138bc75d-0d04-0410-961f-82ee72b054a4>2011-11-10 17:09:04 +0000
commitb8190fde2cd04078f8448576fb021060526b51d5 (patch)
tree07e6f7b8e7f2e100f0948704bfb12de29858cde2 /libitm/Makefile.am
parent15aefa66eea98ad9cfdf9860acb004c18055d46f (diff)
downloadgcc-b8190fde2cd04078f8448576fb021060526b51d5.tar.gz
libitm: Don't add -mavx if the assembler doesn't support avx.
* config/x86/x86_avx.cc: Remove #undef __AVX__ hack. Tidy comments. * Makefile.am (x86_avx.lo): Only add -mavx if ARCH_X86_AVX. * configure.ac (ARCH_X86_AVX): New conditional. * Makefile.in, configure: Rebuild. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@181261 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libitm/Makefile.am')
-rw-r--r--libitm/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/libitm/Makefile.am b/libitm/Makefile.am
index 45789866b4f..b4674a572fc 100644
--- a/libitm/Makefile.am
+++ b/libitm/Makefile.am
@@ -48,6 +48,8 @@ libitm_la_SOURCES = \
if ARCH_X86
libitm_la_SOURCES += x86_sse.cc x86_avx.cc
x86_sse.lo : XCFLAGS += -msse
+endif
+if ARCH_X86_AVX
x86_avx.lo : XCFLAGS += -mavx
endif