summaryrefslogtreecommitdiff
path: root/libiberty/configure.ac
diff options
context:
space:
mode:
authorhjl <hjl@138bc75d-0d04-0410-961f-82ee72b054a4>2009-09-04 14:33:16 +0000
committerhjl <hjl@138bc75d-0d04-0410-961f-82ee72b054a4>2009-09-04 14:33:16 +0000
commit65e17bf6330a6687b995a5ea09c05de3cbd9dc6f (patch)
tree2c388d6661dfc9985b529fd452d81632a23bad4e /libiberty/configure.ac
parent196575476f91521639aaefc61c2238ec874409c8 (diff)
downloadgcc-65e17bf6330a6687b995a5ea09c05de3cbd9dc6f.tar.gz
2009-09-04 Ozkan Sezer <sezeroz@gmail.com>
PR target/39065 * configure.ac: Replace AC_CHECK_TYPE() for intptr_t and uintptr_t with AC_TYPE_INTPTR_T and AC_TYPE_UINTPTR_T. * config.in: Regenerated. * configure: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@151423 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libiberty/configure.ac')
-rw-r--r--libiberty/configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/libiberty/configure.ac b/libiberty/configure.ac
index c34fc10b81b..00dd68dcef2 100644
--- a/libiberty/configure.ac
+++ b/libiberty/configure.ac
@@ -254,9 +254,6 @@ libiberty_AC_DECLARE_ERRNO
# Determine the size of an int for struct fibnode.
AC_CHECK_SIZEOF([int])
-AC_CHECK_TYPE(intptr_t, long)
-AC_CHECK_TYPE(uintptr_t, unsigned long)
-
# Look for a 64-bit type.
AC_MSG_CHECKING([for a 64-bit type])
AC_CACHE_VAL(liberty_cv_uint64,
@@ -290,6 +287,9 @@ if test "$liberty_cv_uint64" != none; then
[Define to an unsigned 64-bit type available in the compiler.])
fi
+AC_TYPE_INTPTR_T
+AC_TYPE_UINTPTR_T
+
# Given the above check, we always have uintptr_t or a fallback
# definition. So define HAVE_UINTPTR_T in case any imported code
# relies on it.