summaryrefslogtreecommitdiff
path: root/libiberty/configure.ac
diff options
context:
space:
mode:
authordj <dj@138bc75d-0d04-0410-961f-82ee72b054a4>2004-01-22 19:10:56 +0000
committerdj <dj@138bc75d-0d04-0410-961f-82ee72b054a4>2004-01-22 19:10:56 +0000
commitacecd7dcb2bfb05164ec5b76bbb0f45ae9a1346b (patch)
tree3c82a4f9075b890c94f602bad300018311f34f4e /libiberty/configure.ac
parentb7f41348bd337cf547becac403702d5af0b18ad5 (diff)
downloadgcc-acecd7dcb2bfb05164ec5b76bbb0f45ae9a1346b.tar.gz
* Makefile.in: Convert to ./ throughout. Rebuild dependencies
with explicit build rules. (VPATH): Remove. (.c.o): Poison. * configure.ac (pexecute, LIBOBJS): Add ./ . * maint-tool: Build dependencies with explicit rules. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@76366 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libiberty/configure.ac')
-rw-r--r--libiberty/configure.ac19
1 files changed, 14 insertions, 5 deletions
diff --git a/libiberty/configure.ac b/libiberty/configure.ac
index eb8a99daa08..3e379cc85a5 100644
--- a/libiberty/configure.ac
+++ b/libiberty/configure.ac
@@ -477,11 +477,11 @@ fi
# Figure out which version of pexecute to use.
case "${host}" in
- *-*-mingw* | *-*-winnt*) pexecute=pex-win32.o ;;
- *-*-msdosdjgpp*) pexecute=pex-djgpp.o ;;
- *-*-msdos*) pexecute=pex-msdos.o ;;
- *-*-os2-emx*) pexecute=pex-os2.o ;;
- *) pexecute=pex-unix.o ;;
+ *-*-mingw* | *-*-winnt*) pexecute=./pex-win32.o ;;
+ *-*-msdosdjgpp*) pexecute=./pex-djgpp.o ;;
+ *-*-msdos*) pexecute=./pex-msdos.o ;;
+ *-*-os2-emx*) pexecute=./pex-os2.o ;;
+ *) pexecute=./pex-unix.o ;;
esac
AC_SUBST(pexecute)
@@ -496,6 +496,15 @@ else
fi
AC_SUBST(INSTALL_DEST)
+L=""
+for l in x $LIBOBJS; do
+ case $l in
+ x) ;;
+ *) L="$L ./$l" ;;
+ esac
+done
+LIBOBJS="$L"
+
# We need multilib support, but only if configuring for the target.
AC_OUTPUT(Makefile testsuite/Makefile,
[test -z "$CONFIG_HEADERS" || echo timestamp > stamp-h