summaryrefslogtreecommitdiff
path: root/libiberty/configure.ac
diff options
context:
space:
mode:
authoraj <aj@138bc75d-0d04-0410-961f-82ee72b054a4>2005-05-28 11:40:59 +0000
committeraj <aj@138bc75d-0d04-0410-961f-82ee72b054a4>2005-05-28 11:40:59 +0000
commit71f27b28ea4c12ab7af9b49492f3a1afeca325f1 (patch)
tree33877dbe0dcb3d58776129b09f97bba8395313c1 /libiberty/configure.ac
parent7e116ea85ce0df5b248a56d854494482095c0c1d (diff)
downloadgcc-71f27b28ea4c12ab7af9b49492f3a1afeca325f1.tar.gz
include:
2005-05-28 Eli Zaretskii <eliz@gnu.org> * libiberty.h: (snprintf) [!HAVE_DECL_SNPRINTF]: Declare if needed. (vsnprintf) [!HAVE_DECL_VSNPRINTF]: Declare if needed. libiberty: 2005-05-28 Eli Zaretskii <eliz@gnu.org> * configure.ac: Add snprintf and vsnprintf to AC_CHEK_DECLS. * config.in, configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@100292 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libiberty/configure.ac')
-rw-r--r--libiberty/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/libiberty/configure.ac b/libiberty/configure.ac
index bd1e4583477..97abc327038 100644
--- a/libiberty/configure.ac
+++ b/libiberty/configure.ac
@@ -282,7 +282,7 @@ if test "x" = "y"; then
sysconf times sbrk gettimeofday ffs snprintf vsnprintf \
pstat_getstatic pstat_getdynamic sysmp getsysinfo table sysctl wait3 wait4 \
realpath canonicalize_file_name __fsetlocking)
- AC_CHECK_DECLS([basename, ffs, asprintf, vasprintf])
+ AC_CHECK_DECLS([basename, ffs, asprintf, vasprintf, snprintf, vsnprintf])
AC_DEFINE(HAVE_SYS_ERRLIST, 1, [Define if you have the sys_errlist variable.])
AC_DEFINE(HAVE_SYS_NERR, 1, [Define if you have the sys_nerr variable.])
AC_DEFINE(HAVE_SYS_SIGLIST, 1, [Define if you have the sys_siglist variable.])
@@ -518,7 +518,7 @@ if test -z "${setobjs}"; then
[AC_MSG_RESULT([no])])
AC_CHECK_FUNCS($checkfuncs)
- AC_CHECK_DECLS([basename, ffs, asprintf, vasprintf])
+ AC_CHECK_DECLS([basename, ffs, asprintf, vasprintf, snprintf, vsnprintf])
AC_CHECK_DECLS([calloc, getenv, malloc, realloc, sbrk])
libiberty_NEED_DECLARATION(canonicalize_file_name)
fi